Pages: [1]
Author Topic: Me7.5 O2 circuit Fried... trying to fix  (Read 436 times)
Jim_Coupe
Hero Member
*****

Karma: +5/-10
Offline Offline

Posts: 562



« on: January 08, 2017, 11:20:25 AM »

Hi,

I opened my ECU (me7.5) and discovered that pin51 was coocked inside ecu.. Pin 51 is Front O2 sensor... I have now repaired the broken copper lane but still have problems.. Any ideas on IC´s or other stuff that i shall check that could be broken in the circuit for o2 sensor. ?
Logged

E85oholic
adam-
Hero Member
*****

Karma: +60/-13
Offline Offline

Posts: 1206


« Reply #1 on: January 08, 2017, 02:18:37 PM »

It's not worth repairing.
Logged

facebook.com/adamforbes92
Jim_Coupe
Hero Member
*****

Karma: +5/-10
Offline Offline

Posts: 562



« Reply #2 on: January 09, 2017, 07:01:49 AM »

Hehe true...I tried to refit some ic's but naaah.. These narrowband me7.5 ecus are cheap. Already have 2 new ecus on the way. But the question is whay coocked the ecus. Hmmm..
Logged

E85oholic
jogtx16v
Full Member
***

Karma: +6/-0
Offline Offline

Posts: 114



« Reply #3 on: January 09, 2017, 08:29:27 AM »

common cause is shorted wiring in o2 sensor wiring.
Logged
Zenerdiode
Newbie
*

Karma: +1/-0
Offline Offline

Posts: 12


« Reply #4 on: January 09, 2017, 01:44:55 PM »

But the question is whay coocked the ecus. Hmmm..

By far the biggest reason is the heater element in the O2 sensor fails short-circuit. This was a massive oversight on manufacturer; not to run the heater supply through a fuse.
Logged
Jim_Coupe
Hero Member
*****

Karma: +5/-10
Offline Offline

Posts: 562



« Reply #5 on: January 10, 2017, 04:31:41 AM »

Ok i just had that thought why didnt they fuse the damn wire.. I think ill solder a fuse on that wire just in case and throw in a new O2 sensor and check the wiring. Dont want to fry more ECUs.
Logged

E85oholic
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.017 seconds with 17 queries. (Pretty URLs adds 0s, 0q)