Pages: [1]
Author Topic: Having issues connecting / writing on bench ME7.1.1  (Read 751 times)
chummmma
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 3


« on: February 21, 2017, 01:30:57 PM »

I have a S4 4.2 V8 ECU    8E2 910 560F .     I read the original with a programmer and wrote a sai off file.     after 1 week I changed the file and now car wont run.    Tried to read via bench with no luck.   I wrote back original file on flash chip and car still wont start or communicate.     

When I read ECU info I get
0x94, System Supplier ECU Software Number: 0x0000,
   0x91, Vehicle Manufacturer ECU Hardware Number: 0x0D, 8E2907560   , 0xFF,
   0x9B, Calibration Date:  0x00001E22, 0x00000000, 0x0000,                ,      ,
   0x9C, Calibration Equiment Software Number: 0x02000000,

If I try to read with the ecu on the bench harness I get
Disabling Windows sleep mode.
Reading ECU flash memory.
ECU reports programming session preconditions have been met.
Negotiating communication timings.
Timing negotiation failed. Communication timings are unchanged.
Requesting security access.
Security access granted.
Starting diagnostic session.
Successfully started diagnostic session.
Negotiating communication timings.
Successfully changed to new communication timings.
Requesting security access.
Security access granted.
Validating flash memory starts at 0x00800000 and ends at 0x00900000.
Validation failed, ECU reports RequestUpload service is not supported. RequestUpload may have been disabled by aftermarket engine software.
Memory layout validation failed.
Starting to read data block.
Calculating flash checksum to determine if reading is necessary for range: 0x00800000 to 0x00804000
Checksum validation routine did not start or complete correctly.
Flash checksum does not match, reading flash data is necessary.
Requesting upload from ECU for address range 0x00800000 to 0x00803FFF.
Request upload from ECU failed, ECU reports service is not supported. Request upload may have been disabled by aftermarket engine software.
Reading ECU flash memory failed. Trying to force ECU to recognize read operation is complete.
Checksum validation routine did not start or complete correctly.
Finished forcing ECU to recognize that failed read operation is complete.
Reading ECU flash memory failed.
100% complete.
Restoring Windows sleep mode.

Anyone have anything I can try?
Logged
chain_slappinS4
Full Member
***

Karma: +10/-8
Offline Offline

Posts: 58


« Reply #1 on: February 28, 2017, 03:01:18 AM »

make sure pin 21- immo, has power..

Sent from my SAMSUNG-SM-G935A using Tapatalk
Logged

microsoft asked me to install windows nt or better, so i installed Solaris!!
chummmma
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 3


« Reply #2 on: March 16, 2017, 02:16:24 PM »

pin 21 has power.   VCDS shows a bunch of blank info or 0000000
Logged
ktm733
Hero Member
*****

Karma: +13/-0
Offline Offline

Posts: 602



« Reply #3 on: March 16, 2017, 04:46:12 PM »

Death code in Eeprom possibly? Writing original won't change it.
Logged
4ringpieces
Full Member
***

Karma: +3/-3
Offline Offline

Posts: 209


« Reply #4 on: March 17, 2017, 01:18:36 AM »

Change flash chip for new and flash standard file on it
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.016 seconds with 16 queries. (Pretty URLs adds 0.001s, 0q)