Pages: [1]
Author Topic: SAI REMOVE PLEASE HELP  (Read 1969 times)
tao13
Full Member
***

Karma: +0/-9
Offline Offline

Posts: 184


« on: December 22, 2017, 07:35:07 AM »

Hello all.
I removed SAI pump from circuit (hose and wire) and i removed the N112 for it.
I understand exist a relay j299 for SAI? I must remove it or leave it there?
I want to the ECU skip fuel calculation for SAI and make a new calculation without it.
Please tell me if i change ESKONF by setting the appropriate bitpairs SLV (N112) and SLP (J299) to 11 ut is enought or it is only for not see error/ DTC in VCDS?
I must make changes in other parts like WIKI reference
"The first method sets the monitor to unsupported (falsely shown as PASSED in VCDS):

    CDSLS to 0
    CWKONABG bit 2 to 0 (e.g. change from 5 to 1).

However, if your SAI pump is dead or failing, it will cause cold start issues.[71] In addition, it will only show SAI unsupported, and NOT truly passed. To fix this, unplug the pump from the relay and modify

    MSLUB (0x1A698)
    MSLBAS (0x183CC)"

What is the best methode?
MANY MANY THANKS.
Logged
Marty
Hero Member
*****

Karma: +126/-81
Offline Offline

Posts: 1303


« Reply #1 on: December 22, 2017, 07:59:33 AM »

Hello all.
I removed SAI pump from circuit (hose and wire) and i removed the N112 for it.
I understand exist a relay j299 for SAI? I must remove it or leave it there?
I want to the ECU skip fuel calculation for SAI and make a new calculation without it.
Please tell me if i change ESKONF by setting the appropriate bitpairs SLV (N112) and SLP (J299) to 11 ut is enought or it is only for not see error/ DTC in VCDS?
I must make changes in other parts like WIKI reference
"The first method sets the monitor to unsupported (falsely shown as PASSED in VCDS):

    CDSLS to 0
    CWKONABG bit 2 to 0 (e.g. change from 5 to 1).

However, if your SAI pump is dead or failing, it will cause cold start issues.[71] In addition, it will only show SAI unsupported, and NOT truly passed. To fix this, unplug the pump from the relay and modify

    MSLUB (0x1A698)
    MSLBAS (0x183CC)"

What is the best methode?
MANY MANY THANKS.

lol is this a joke?
Logged

tao13
Full Member
***

Karma: +0/-9
Offline Offline

Posts: 184


« Reply #2 on: December 22, 2017, 10:29:44 AM »

WHERE YOU SAW A JOKE???
I don't understand and i read WIKI.
Can you explain more clear about ESKONF if you are a GENIUS???
ESKONF exclude them from "fuel" calculation?
Logged
Carsinc
Sr. Member
****

Karma: +14/-2
Offline Offline

Posts: 448


« Reply #3 on: December 22, 2017, 06:42:23 PM »

Ok everything else aside, what are you doing with your car in the first say 90 seconds after a cold start the you would
care about fueling?Huh
Logged
tao13
Full Member
***

Karma: +0/-9
Offline Offline

Posts: 184


« Reply #4 on: December 23, 2017, 04:19:03 AM »

akk modification for removed sai and evap are done
will see tommorow at a cold weather
Logged
tao13
Full Member
***

Karma: +0/-9
Offline Offline

Posts: 184


« Reply #5 on: December 24, 2017, 01:38:15 AM »

AT -2 C degree car start wery well at 1200 rpm and after 15 seconds i begin to drive and after 500m the car stay very nice at 850 rpm
After water temp was 90 degree car stay at normal rpm aproximatly 750
All readlines test was passed in vcds for SAI end EVAP
SO............works........

ESKONF with EVAP and SAI removed
original  AA FF 00 30 FF F8 30
modified AA   FF 00   33 FF   FB 3C

NEED your help for N249 It is removed from my car too with vaccum reservoir and DV is connected directly to manifold
1.If i remove n249 from eskonf this is correct variable i must change "ULT/LDUVS=N249 Schubumluftventil" Huh
2.I must modify other codewards to remove complete function for it?
3.If all function for n249 are remove the boost will feel otherwise?

MANY thanks again to all.
« Last Edit: December 24, 2017, 03:21:38 AM by tao13 » Logged
tao13
Full Member
***

Karma: +0/-9
Offline Offline

Posts: 184


« Reply #6 on: December 25, 2017, 03:29:00 AM »

Yesterday (please see the post before EVAP and SAI removed from code like WIKI said) the car works greate at -2 degree.
Today is 12 degree and the car starts ok but after 10 seconds when i want to drive , it was very much fuel and tried to stop.
After drive 5 km and water was at 90 degree the car not work ok , some lose power and acceleration is very hard.
The idle is not stable (730-780rpm) and the afr is not stable too it fluctuates between 12.8 and 16.5
I had a removed catalysator from 10000km and not have any error but today after modified the file for ecu with modification for evap and sai i received this error
16804 - Catalyst System; Bank 1
            P0420 - 35-00 - Efficiency Below Threshold

In vcds the readlines for evap and sai passed but o2 and catalyst NOT.

Readiness Status: 0110 0001
Exhaust Gas Recirculation: Passed
Oxygen Sensor Heating: Failed or Incomplete
Oxygen Sensor(s): Failed or Incomplete
Air Conditioning: Passed
Secondary Air Injection: Passed
Evaporative Emissions: Passed
Catalyst Heating: Passed
Catalytic Converter(s): Failed or Incomplete

In obd torque for evap and sai , wrote "NOT SUPPORTED".
Please give me your advice.
WHAT can be?
Can be the ecu is in its first 50 km after i wrote the new file?
Must remove the rear O2 and cat ( O2 is plugged on car but without cat)?
Maybe now the ecu is much sensible without SAI OR EVAP functions and feel bad rear O2 sensor?

MERRY CHRISTMAS and thanks for your time!
« Last Edit: December 26, 2017, 05:26:03 AM by tao13 » Logged
tao13
Full Member
***

Karma: +0/-9
Offline Offline

Posts: 184


« Reply #7 on: December 27, 2017, 01:52:46 PM »

CONCLUSIONS!!!!

My customisation : EVAP AND SAI was removed from car , CAT removed from car  , downpipe 76mm , rear O2 sensor on the car.

Before made changes (remove from soft) for evap and sai the car works very well and starts well at -10 degree and the consuption is very well for the city mode only with readlines test not passed for evap and sai in vcds.

After i made change like WIKI page said for EVAP and SAI my car:
1. not start well at -3 degree
2. not start well at 12 degree very much fuel on ehaust
3. consumption is too high 20% and before was 14-15%
4. evap and sai was lied in readlines VDCS - passed
5. appear error for catalysator (but after 10.000km - not have without this modification from wiki page)
6. car not work well -lost power
AND nobody answer ALL told to read the wiki.................

SO .....................what do you think?

THANKS

« Last Edit: December 28, 2017, 05:09:43 AM by tao13 » Logged
adam-
Hero Member
*****

Karma: +84/-23
Offline Offline

Posts: 1762


« Reply #8 on: December 29, 2017, 12:54:29 AM »

Post the file.
Logged
tao13
Full Member
***

Karma: +0/-9
Offline Offline

Posts: 184


« Reply #9 on: December 29, 2017, 05:49:40 AM »

THANKS to "rogerius" , GREAT MAN!
At his advice i modified the CWKONABG from 5 to 0 not to 1.
Car works good now with a good start at 7 degree and the consumption is ok.
Power it is ok right now.
Only problem but i think i need to remove cat from software :
16804 - catalyst system: bank1 p0420 - 35 - 00 eficiency below threshold

I have the cat removed and downpipe 76mm but rear 02 sensor is on the car.
If you have any advice please write to me.
Thanks and Thanks again ROGERIUS!!
« Last Edit: December 29, 2017, 08:32:50 AM by tao13 » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.019 seconds with 17 queries. (Pretty URLs adds 0s, 0q)