Pages: [1]
Author Topic: Audi A4 1.8T - 8E0909518AS - Removing Revo  (Read 6302 times)
JamesG60
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 10


« on: February 05, 2018, 06:39:23 PM »

Hi, I'm hoping someone can help me because I'm a bit stuck.
I have an ecu (ME7.5 8E0909518AS) from an A4 that's previously (and unknown to the current owner) had a Revo trial. I say trial because its slow as hell apparently.

This ECU was brought to me by a friend who couldn't get into it with MPPS. I pulled the 29f800bb and 95040 off and read them in an eprom burner then rewrote both with standard files that I found online (not the best approach but I haven't got the originals!!!).
Soldered everything back, I can now get in with MPPS, VCDS etc. Car starts but cuts after 2 seconds in classic VAG immobiliser fashion and the dash displays safe.

Exactly what I was expecting.

So, I then immo off the 95040 (bytes 12 and 22 to 02, decrement 1E and 2E by 1). Same thing.

Looking at the 95040 data, it looks as though the 1st line is missing (file offset different for some reason?) so I tried editing bytes 02 and 12 to 02 and decrementing 0E and 1E by 1. Same thing again.

If I flash the Revo file and 95040 back then the car won't start, can't read with MPPS (but can ID). So it looks like the Revo 95040 data has been modified by something along the way.


I've attached the files (as zip files) I'm using along with the Revo files that previously, once upon a time, I'm assured did work (though I have never seen the car with my own eyes).

Is there a different immo off procedure for this particular flavour of ME7.5?
I've never had a problem swapping VW ME7.5 ECUs after immo off'ing them so I can't see why this would be any different.

Oh please, someone have some semblance of an idea...

Cheers
James


EDIT: 8E0909518AS - 95040 - Original.bin is missing at least the first line. It looks to be a partial read of the RAM via OBD. Don't use it!
« Last Edit: February 07, 2018, 06:06:44 AM by JamesG60 » Logged
_nameless
Hero Member
*****

Karma: +327/-456
Offline Offline

Posts: 2733



« Reply #1 on: February 05, 2018, 07:52:12 PM »

Find a eeprom from a b6 a4. Immo off it and flash a stock tune. Revo is in the eeprom too
Logged

If you are in the market for a tune and would like the ease of downloading and flashing a dyno tested tune for a fair price check out https://instatune.sellfy.store/
JamesG60
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 10


« Reply #2 on: February 06, 2018, 01:44:03 AM »

Find a eeprom from a b6 a4. Immo off it and flash a stock tune. Revo is in the eeprom too

Hi Marty, that's exactly what I tried and it resulted in a no start with safe on the dash.
This EEPROM dump is not easy to find. I could only find 1 by searching for an immo off solution and using the file the OP was asking for help with. I don't know if this dump is even correct. The structure looks different to that of any other ME7.5 95040 that i've seen.
« Last Edit: February 06, 2018, 01:45:37 AM by JamesG60 » Logged
adam-
Hero Member
*****

Karma: +122/-33
Offline Offline

Posts: 2178


« Reply #3 on: February 06, 2018, 03:19:30 AM »

Get EEPROM and flash and code properly.

Likely your immo off is wrong.  Use the tool here to do it for you, never had an issue with it.  Likely the EEPROM is wrong. Smiley
Logged
_nameless
Hero Member
*****

Karma: +327/-456
Offline Offline

Posts: 2733



« Reply #4 on: February 06, 2018, 04:39:03 AM »

Hi Marty, that's exactly what I tried and it resulted in a no start with safe on the dash.
This EEPROM dump is not easy to find. I could only find 1 by searching for an immo off solution and using the file the OP was asking for help with. I don't know if this dump is even correct. The structure looks different to that of any other ME7.5 95040 that i've seen.
immo off is the same. All vag me7 have the same layout. Dobt use any revo bits or it wont work. Use your new immo off file and a stock flash file. It will work just fine
Logged

If you are in the market for a tune and would like the ease of downloading and flashing a dyno tested tune for a fair price check out https://instatune.sellfy.store/
JamesG60
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 10


« Reply #5 on: February 06, 2018, 05:15:07 AM »

immo off is the same. All vag me7 have the same layout. Dobt use any revo bits or it wont work. Use your new immo off file and a stock flash file. It will work just fine

The new file (95040 - Original) appears to be different to other me7.5s. I don't know if this is where I just found it online or whether it is correct and just has a different structure.

It appears the immo codeword is in page 0 (bytes 00-0F) with a backup page in page 1 (bytes 10-1F) where as these are normally in pages 1 and 2.

If I open the 95040 - Original that i found online with 95040tool or eepromtool it doesn't show immo status, vin, or immo data properly, only showing a small ? glyph on these lines.
If I open the 95040 - revo (that came on this ecu when it arrived with me) eepromtool shows everything as it should.

I just want someone to look at the 95040 - Original and tell me whether its correct (or looks like it) or whether like to me, it seems completely wrong.
For reference, this is where I found this supposed original file - http://nefariousmotorsports.com/forum/index.php?topic=12097.0title=

Logged
JamesG60
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 10


« Reply #6 on: February 06, 2018, 05:20:07 AM »

Get EEPROM and flash and code properly.

Likely your immo off is wrong.  Use the tool here to do it for you, never had an issue with it.  Likely the EEPROM is wrong. Smiley

bytes 12 and 22 from 01 to 02 (byte 12 was 1, byte 22 was 3 - should be the same), then decrement 1e and 2e by 1

I also tried this on pages 0 and 1 (which to me look like the immo pages, with skc on the pages directly below).

I've attached the 2 95040 files I tried the immo off in. Neither work
« Last Edit: February 06, 2018, 05:25:47 AM by JamesG60 » Logged
_nameless
Hero Member
*****

Karma: +327/-456
Offline Offline

Posts: 2733



« Reply #7 on: February 06, 2018, 04:29:17 PM »

Theres a few 95040 reads on this form that are not right bits are off. You can even use a 95040 eeprom from a golf or jetta ns it will work if immo offed. Youll have a asr light and cide for wrong eeprom but it wont show a cel and it will run and drive. I myself have had a immo off issue with late model me7.5 and come to fi d out it was a bad bin i got from this site
Logged

If you are in the market for a tune and would like the ease of downloading and flashing a dyno tested tune for a fair price check out https://instatune.sellfy.store/
JamesG60
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 10


« Reply #8 on: February 06, 2018, 04:49:23 PM »

Theres a few 95040 reads on this form that are not right bits are off. You can even use a 95040 eeprom from a golf or jetta ns it will work if immo offed. Youll have a asr light and cide for wrong eeprom but it wont show a cel and it will run and drive. I myself have had a immo off issue with late model me7.5 and come to fi d out it was a bad bin i got from this site

I found a 95040 dump from a 8E0909518 and I've edited it with the software number and version, cluster info, immo code, skc, vin and also immo offed it for good measure. I'll try it in the morning.
I think you're right, that dump I found must have been wrong.
Logged
JamesG60
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 10


« Reply #9 on: February 07, 2018, 05:51:27 AM »

Doesn't even start with "8E0909518AS - 95040 - new - Immo Off.bin" (starts 20 20 20 20 20 5A) Which is an original file from 8E0909518 which I modified with vin, cluster code etc.

Starts and cuts out with "me7.5 immo off.bin". (starts 12 68 30 14 65 DB)

I'm going to modify "me7.5 immo off.bin" with the correct cluster info, immo code and vin (double checked against the dash last night) and see if that helps.

« Last Edit: February 07, 2018, 07:05:27 AM by JamesG60 » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.032 seconds with 16 queries. (Pretty URLs adds 0s, 0q)