Pages: [1]
Author Topic: Helpful guide to Jeager Magneti Marelli Clusters(hopefully)  (Read 278 times)
mervhendrix13
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 2


« on: April 17, 2018, 12:15:26 PM »

Just joined and didn't want my first post to be "I've a problem please fix it".
So I read everything I could in here and managed to fix the issue with the advice given.
Many many thanks for the great posts. You guys know your stuff. Smiley
So by way of thank you I'll like to share what I found works and what didn't. I'm no expert by any means so this is aimed at folk who have very little knowledge and are just trying to resolve an issue like me. Please feel free to correct any obvious mistakes.

Car involved Audi '05 TT  with the Jeager Magneti Marelli cluster. These clustesr are garbage, I lost all lcd screens and temperature gauge was dead.  I got a replacement fully working and wanted to do the swap myself.

This is an immo3 cluster so has SKC located in cluster and Engine ECU.

Firstly I wasted a lot of time faffing about with win 7 and win 10 laptops, my advice is life is much easier if you get hold off or reinstall xp. Saves time and effort trying to get drivers to work.

 First programme I tried was Vag tacho.  Worked fine for replacement cluster but gave 2 different pins for the original. Neither of which turned out to be right.

I then tried Vag Commander 1.4, 2.5 and 5.5.  Only 1.4 and 2.5 can read these cluster as they read it via K line which 5.5 can't do.

I picked Shadow 3 TT from the options given and got a bin file. Also tried MM-direct which crashed commander each time.  I intended to post bin file here and ask for help but thought I'd try the engine ecu first.

Engine ECU with commander 1.4 and 2.5 reads fine using the wakeup pattern 11. I used a free online Hex Editor and found a imnuts guide to retrieve SKC from VW/Audi immo3.  Line 32 and 33 reversed and converted to decimal. SKC Pin found.

Note commander tells you this on the read epprom page in the field 'login' when you read it attached to the car.  Didn't realise this at the time as I had saved the bin file and opened it later in the house and it leaves the field blank.

I then followed the VCDS Ross tech guide and got cluster working. This is the easy part.

My advice is if your cluster is broken in anyway the chances are anything you going to get from it is rubbish.  Go for the Engine ECU from the start and ignore the cluster, as long as the replacement is good tacho should be fine, if not commander will work but you'll need someone to decipher your dump file.

I had read about de-soldering epprom chip but from what I've read this cluster doesn't have one its built into the clusters board.

Also downloaded and tried using vag epprom programmer. Doesn't work for this cluster so don't bother.

I've attached the relevant bin files for reference should they be of use to someone.

I read through a lot of forums before coming across this one, with a lot of conflicting info and nonsense. If you've found this searching for the same issue this forum is by far the most knowledgeable I've found.

Thanks for the great info Smiley



Logged
slappynuts
Jr. Member
**

Karma: +0/-0
Offline Offline

Posts: 48


« Reply #1 on: June 01, 2018, 04:10:23 PM »

So you were able to get the pin from the cluster? I have been fighting with junk clusters on my car since I bought it and had pretty much given up.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.013 seconds with 16 queries. (Pretty URLs adds 0s, 0q)