Pages: [1]
Author Topic: Help with gasoline in oil  (Read 1539 times)
golfputtputt
Sr. Member
****

Karma: +2/-3
Offline Offline

Posts: 293


« on: August 07, 2018, 10:45:13 AM »

My oil change smells like gasoline.
I have a bunch of ideas for tests, tests I've done and tests I need to repeat. I'm looking for more ideas for hunting down the possible cause of this problem.

car specs:
1.9T (bored 1.8T) supertech pistons 9.6:1 compression. 'street spec' ring gap as per supertech's piston spec sheet, AKA, tightest ring gap speced. 'thirds' ring gap placement, not half and half. New valve seals, valve seats checked for sealing.

What I've done:
Change sparkplugs from champion copper to NGK v-power copper (gapped to .027") Champion plugs were very clean, no signs of lean or rich condition, gap measured to be .027" when removed.
coil packs produce 40kv with adjustable tester
check FPR hose for leaks/gas. Smells like gas when pulled off but no fluid in the line, bone dry.
vacuum tested FPR, maintained solid 27inHG
Did leaky injector pressure test (although genuine EV14 genesis 550's are brand new) 60 PSI test each, no leaks.

What I need to do:
check fuel pressure
cylinder leak down test

What I need to do again:
compression test (did a while ago, compression was around 170-180 for all cylinders about 7-8 months ago)
change oil after I find out whats going on.

Does anyone have any other ideas as to what could be causing gasoline to get into oil and have any other tests I could run? Could Wall wetting cause this? could calibration cause this? I'll post a log after work.
I come to you guys cuz ya'll are smart n' stuff.

« Last Edit: August 08, 2018, 07:27:33 PM by golfputtputt » Logged
jogtx16v
Full Member
***

Karma: +6/-0
Offline Offline

Posts: 130



« Reply #1 on: August 09, 2018, 06:36:01 PM »

im not an expert, but what your air fuel ratio say ?
Logged
golfputtputt
Sr. Member
****

Karma: +2/-3
Offline Offline

Posts: 293


« Reply #2 on: August 09, 2018, 07:03:39 PM »

sorry, the log is too big to post..? so i put it in a zip

It looks like its hunting at idle and part throttle. definitely at idle.
Could someone explain why AFR desired dips to 11.771 on throttle closing?

Also, yes according to that log, my WOT fueling is def not doing what it's supposed to, that's obvious but off topic.
« Last Edit: August 10, 2018, 10:03:20 AM by golfputtputt » Logged
golfputtputt
Sr. Member
****

Karma: +2/-3
Offline Offline

Posts: 293


« Reply #3 on: August 12, 2018, 06:30:16 PM »

looked at plugs, they did not appear to be running rich at all, but alas, there it is right in the data. Enriching on part throttle. I definitely screwed something up with my part throttle tuning.

Attached is the data sheet listing all of my edited maps, my bin, the latest log. My guess is FKKVS is all screwed up. I used the "FKKVS fixer" and prob shouldn't have done that. Can anyone confirm that this is what I messed up?

O2's primary and auxiliary are positioned immediately after the turbocharger and are new wideband (primary) bosch brand non oem. Perhaps primary is a dud? is there any way to test an o2?
« Last Edit: August 12, 2018, 07:48:59 PM by golfputtputt » Logged
golfputtputt
Sr. Member
****

Karma: +2/-3
Offline Offline

Posts: 293


« Reply #4 on: August 16, 2018, 10:27:05 AM »

This is post o2 replacement. Doesn't seem to have solved the issue.

Can anyone help with these AFR issues?

need to 1 FKKVS and ponder. KFBAKL and KFVAKL?

Trims are +0.6 idle 0.0 partial with 550 ev14’s
« Last Edit: August 16, 2018, 02:50:00 PM by golfputtputt » Logged
golfputtputt
Sr. Member
****

Karma: +2/-3
Offline Offline

Posts: 293


« Reply #5 on: August 22, 2018, 07:29:50 PM »

new FPR, new fuel rail, new injectors, new fuel filter, new fuel pump, new fuel pump housing, new lines in the engine bay. Only thing old is lines from tank to bay. No change.

Added a trumpet to inside of cone filter. Figuring out way to get airbox back in place but I doubt that's the issue.

reduced VAKL/BAKl by .40. Think I went the wrong way. I don't understand why the map goes all the way down to -30 deg C-->10.5 Z axis. I want to view the VAKL/BAKL flag but in not sure the variable or what the address is.

Any suggestions for variables to log/look at?
« Last Edit: August 22, 2018, 07:39:38 PM by golfputtputt » Logged
aef
Hero Member
*****

Karma: +37/-13
Offline Offline

Posts: 1008


« Reply #6 on: August 23, 2018, 01:19:12 AM »

blowoff valve instead of recirc valve?
Logged
golfputtputt
Sr. Member
****

Karma: +2/-3
Offline Offline

Posts: 293


« Reply #7 on: August 23, 2018, 05:14:26 AM »

Mod list:

Custom Intake manifold, same runners, larger plenum, flip throttle side, same as TT225
EV14 550CC injectors
Insulated intake gasket spacer
Euro valve cover
LS2 silverado coil packs mounted on valve cover
Custom spark plug wires using copper cables from VR6 engines, no resistance
NGK V-power copper resistance plugs
Eliminator GT2860RS kit with up pipe (Wire tied Bolts to prevent backing off)
Turbosmart external wastegate actuator 7 PSI spring
custom Turbo inlet pipe
Chinese Catless 3"-2.25" downpipe
Primary and secondary Lambda sensors relocated to right after turbo. (OEM bosch wideband)
Magnaflow 2 muffler 2.25" catback
Turboblanket
ceramic coated exhaust components up to down pipe
heatwrapped exhaust manifold and up pipe
Air to water intercooler
Bosch cobra AWIC pump
Front mount 2" thick AWIC heat exchanger
3/4" ID AWIC lines
Vibratechnics "street" engine mounts
Braided steel power steering pressure hose
Vent to atmosphere (completely), two 3/4" ID line catch can
PCV system delete
Washer bottle delete
Evap system (in bay) delete
Secondary air injection system delete
n249 delete
Southbend TDI 400Ft/lb clutch w/25? lb single mass flywheel
Rebuilt gearbox w/ fresh seals and bearings
Wavetrac LSD
1.8 bored out to 1.9
Supertech oversized 9.6:1 coated pistons
Integrated engineering rifle drilled conrods
ACL race tri-metal main bearings
Audi S4 Oil/water cooler
Wix 51333 "big Kahuna" oil filter
AEM washable cone filter
Porsche 981 cayman front calipers mounted to 337 discs
Battery relocation 1/0 wire

Series of suspension mods
series of shifting system mods (manual transmission 5 speed)

Everything not listed is OEM but to note particulars:
Fuel pump
Fuel lines
Fuel rail
3 bar FPR
Recirc valve
n75
All gaskets including head gasket
AC system
Power steering system (excluding pressure pipe)
cooling system (excluding some plastic parts being replaced with aluminum)
oiling system
ABS system
Brake hydraulic system
clutch hydraulic system
MAF/MAF housing/Air straightener
Trumpet from oem airbox mounted directly before MAF intake
IAT sensor/placement
Brake booster/check valve
heater core


Here is a log before I did any of those things. I'm pretty sure the only mod I had back then was a cone filter. Symptoms still present back then. SO, yes Oem airbox outfit is high on the list as that's the seemingly only common denominator. Possibly brake booster leak, internal or into cabin. one of the few things I haven't checked or replaced ever. Did do a leak check using multiple methods (smoke, carb clean, pressure/soapy water)

also, the forum upload system times out with every csv I try and upload, zips seem to work

will log:
fukabak_w - factor adaptive transient control (cold engine) BA   
fukabaw_w - factor adaptive transient control (hot engine) BA
fukavak_w - factor adaptive transient control (cold engine) VA   
fukavaw_w - factor adaptive transient control (hot engine) VA

update:
fukabaw_w was the only one out at .9425. All others are 1, Not it.

Looking into wall film tuning ESUK. Anyone know the address of rlp_w (or other important variables, rkukg_w?)? looking to see if it's off, if maps WFRL, ZBALM, ZVALM, ZBAKM, ZVAKM, KFAVAK, KFABAK need tuning. Does anyone have experience with wall-film tuning?

Theory: The non AFRdesired fluctuations are wall film component errors and the AFRdesired enrichment upon decel is...something else.
« Last Edit: August 24, 2018, 11:09:05 AM by golfputtputt » Logged
golfputtputt
Sr. Member
****

Karma: +2/-3
Offline Offline

Posts: 293


« Reply #8 on: August 28, 2018, 06:11:04 PM »

Can anyone assist?
Logged
golfputtputt
Sr. Member
****

Karma: +2/-3
Offline Offline

Posts: 293


« Reply #9 on: September 11, 2018, 08:30:34 PM »

Can anyone explain why my Lamsons/Lamsbg enriches during throttle tip in after throttle close/shift? Trying to get rid of it and I cant find why its enriching.
Logged
golfputtputt
Sr. Member
****

Karma: +2/-3
Offline Offline

Posts: 293


« Reply #10 on: September 19, 2018, 06:10:05 AM »

Found out what was contributing to my requested AFR. Translated LAMKO and logged the sub-module LAMSEL variables:

lamau_w
lamlash_w
flamkh
dlamatr_w
lamdkt_w
lamsubg_w
lamlshv_w
lamnswl_w
lamelsh_w
lambts_w
lamfa_w

it was lamka_w from the map LAMKAML. set to all 1's. done
Next series of issues I'm having is idle oscillation and warmup crap running (one problem at a time though, idle first)

I also fixed up my non throttle completely closed/open AFR by using audi tt FKKVS ms axis values which increased resolution in the lower rpms <3000 which helped smooth things out a lot. Ran it through the fixer about 7 times. I need to figure out how to fine to KFKHFM. Can you adapt the fixer to work on KFKHFM? since they're all multiplicative.

From the log/png you can see that idle sucks at startup, oscillating hard. then, it levels out, then, once warm, goes back to being shit but in the opposite direction. Speed deviation also gets bad after warmup. Anyone have any ideas?
« Last Edit: September 19, 2018, 06:25:07 AM by golfputtputt » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.021 seconds with 17 queries. (Pretty URLs adds 0s, 0q)