Pages: [1]
Author Topic: S4 M-box reach at WOT, strange behavior at 3k-3,5k rpm  (Read 717 times)
Imho
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 10


« on: November 05, 2018, 10:01:21 AM »

Hello,
My car is 99' S4 B5 on stage 3. K04 hybrid, hi flow exhaust manifold, RS4 fuel pump, stock FPR, 550ccm injectors etc..
I have 2 issues on my tune first one is that car is running very reach seems it does not fallow lamfa - i have external innovative motorsport wideband AFR (calibrated on free air) and it shows AFR around 9 at the red line. I run out of idea where is the mistake in my tune..



second problem is jerking after turbos spool up around 3000-3500 rpm my AFR is jumping on guage and its visible on o2 sensors voltage:


ignition coils checked, ignition module replaced, fuel injectors replaced - no clue.
logs:
https://drive.google.com/open?id=1xvPxHrJJplEryAwdRi_d7foTNoDJ8b2V



« Last Edit: December 02, 2018, 07:20:12 AM by Imho » Logged
nyet
Administrator
Hero Member
*****

Karma: +385/-44
Offline Offline

Posts: 8817


WWW
« Reply #1 on: November 05, 2018, 09:32:09 PM »

Limp

No codes?
Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
Imho
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 10


« Reply #2 on: November 06, 2018, 12:59:39 AM »

sorry i posted wrong log... yes in that one car went to safe mode..

correct log:
https://drive.google.com/open?id=1xvPxHrJJplEryAwdRi_d7foTNoDJ8b2V
Logged
nyet
Administrator
Hero Member
*****

Karma: +385/-44
Offline Offline

Posts: 8817


WWW
« Reply #3 on: November 06, 2018, 01:04:02 AM »

Misfires.

check coilpacks, plugs, ICMs etc.

9 is too much fuel.
Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
Imho
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 10


« Reply #4 on: November 06, 2018, 02:39:39 AM »

there is no missfire faults and car goes smothly after 5k rpm.
the only problem with missfire is on low RPM when the jerking happens but there seems to be very lean (on external guage and o2 voltage jumps low)

anyway ecu shall keep the afr at lambda 0.81 as in software.
tagbts is set to ~920 celcius degrees

btw EGT sensors are removed from software... maybe i did it wrong way ?
Logged
nyet
Administrator
Hero Member
*****

Karma: +385/-44
Offline Offline

Posts: 8817


WWW
« Reply #5 on: November 06, 2018, 09:14:45 AM »

Misfire detection will not always trigger a DTC.

Log misfire counters themselves.
Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
armageddon
Sr. Member
****

Karma: +17/-1
Offline Offline

Posts: 298


« Reply #6 on: November 09, 2018, 01:03:47 PM »

I had a problem with misfires that did not throw any code neither visible on logs, and yes, file had misfire recognition. I found the culprit cylinder by looking at knock voltage


Its lean because of unburned fuel mixture
« Last Edit: November 09, 2018, 01:05:29 PM by armageddon » Logged
Imho
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 10


« Reply #7 on: November 10, 2018, 12:03:01 PM »

I had a problem with misfires that did not throw any code neither visible on logs, and yes, file had misfire recognition. I found the culprit cylinder by looking at knock voltage


Its lean because of unburned fuel mixture

sorry but seems you are mixing.. knock is not a missfire so checking knock voltage gives you nothing and unburned fuel makes it reach not lean..
Logged
armageddon
Sr. Member
****

Karma: +17/-1
Offline Offline

Posts: 298


« Reply #8 on: November 10, 2018, 03:46:02 PM »

sorry but seems you are mixing.. knock is not a missfire so checking knock voltage gives you nothing and unburned fuel makes it reach not lean..

I was just giving my experience as how I find my misfire problem, take it as you wish.

You are right, misfires will cause rich mixture, but lamdba sensors do not read gas, do they? if oxigen is not buned it will cause false lean condiction
Logged
roman_tyk
Full Member
***

Karma: +0/-0
Offline Offline

Posts: 82


« Reply #9 on: November 26, 2018, 01:30:21 AM »

If you have KFFDLBTS=0 and TAGBTS=930C, car fueling should run based on LAMFA map (most reach point 0.81AFR)
Its strange that you see on external gauge afr=8-9. There must be some enchrichment enabled

from logs on WOT (6800rpm, line 187):

lamsbg = 0.81
lamsbg_2 = 0.81

usvk = 0.91V
usvk_2 = 0.91V

should be AFR about 11-11.5 not so reach...
Logged
Imho
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 10


« Reply #10 on: December 02, 2018, 02:54:30 AM »

If you have KFFDLBTS=0 and TAGBTS=930C, car fueling should run based on LAMFA map (most reach point 0.81AFR)
Its strange that you see on external gauge afr=8-9. There must be some enchrichment enabled

from logs on WOT (6800rpm, line 187):

lamsbg = 0.81
lamsbg_2 = 0.81

usvk = 0.91V
usvk_2 = 0.91V

should be AFR about 11-11.5 not so reach...

that is the case in my opinoin car drives in "enrichment mode" thats why does not fallow LAMFA.
I just cannot find reason, can someone check if i completely deleted EGT sensors ?
Logged
nyet
Administrator
Hero Member
*****

Karma: +385/-44
Offline Offline

Posts: 8817


WWW
« Reply #11 on: December 02, 2018, 11:05:22 AM »

The log above you posted follows lamfa.

No need to check for EGT. Everything you need is in your logs.

Hmm i should fix that degrees bug.
Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.019 seconds with 17 queries. (Pretty URLs adds 0s, 0q)