Pages: 1 [2]
Author Topic: SuperCharger and SpeedDensity  (Read 2529 times)
MasterJJ406
Jr. Member
**

Karma: +1/-0
Offline Offline

Posts: 35


« Reply #15 on: January 28, 2019, 02:39:21 PM »

I will try to find KFPBRK because I don't have this map. It looks more interesting with RPM and rl_W axes.

Thanks
Logged
MasterJJ406
Jr. Member
**

Karma: +1/-0
Offline Offline

Posts: 35


« Reply #16 on: January 30, 2019, 02:53:18 PM »

I've looked into WDKUGDN and I have to say that I am not confident with my last statement with throttle.

Btw I've found KFPBRK but it has ps_w(0,039063) axis instead of rl_w. It's interesting but I have this difference in KFMDS too.
It was located between KFURLE (10x20) and KFPRGE(10x20) and it's almost same size (12x20). So I think this is it.

I am thinking about new options now... Smiley

thanks a lot
Logged
MasterJJ406
Jr. Member
**

Karma: +1/-0
Offline Offline

Posts: 35


« Reply #17 on: February 02, 2019, 01:12:15 PM »

Good news!
it's working!
The problem was pressure limit, because when I reached 1100mBar car stopped using MAP sensor signal for the rest of the time. Some kind of limp mode.
I've increased all cells in KFPSDMX to 2000mBar and now it calculates positive boost with upgraded MAP sensor Smiley

Suprisingly up to 2000RPM there is no problem with fueling (WOT, part throttle).
Above 2000RPM it gets lean and about 3 000 RPM very lean and in higher RPM it gets slightly better.

So I will concentrate to fix fueling first.

Logged
MasterJJ406
Jr. Member
**

Karma: +1/-0
Offline Offline

Posts: 35


« Reply #18 on: February 15, 2019, 01:28:36 PM »

Guys you are experienced so please give me little advice.

I have stock injectors and I thought that I will reach injector limit at high engine speed during WOT because there is less time for fuel injection.
So I set KFPBRK for whole RPM range at 1000,1300hPa to 1,3 and now I am getting about +-12,0 AFR above 4000RPM. Good.
But up to 4000RPM it gets very lean about 15,5 AFR.
It looks like this is related to VTC and really good efficiency with advanced CAM timing.
So I've tried to increase KFURLE with no change.


So guys what do you think? is it possible to reach injector limit at lower RPM instead of higher RPM? Or KFPBRK values are far away?

One thing... Without supercharger I had in these RPM region with VTC ON 25% more fuel thru FKKVS and tested on dyno that there was about 25% more torque.


I already have bigger injectors ready to install but still I can't find KRKTE.

Thanks for help




Logged
prj
Hero Member
*****

Karma: +359/-78
Offline Offline

Posts: 3923


« Reply #19 on: February 17, 2019, 01:39:44 PM »

Log IPW.
Logged
MasterJJ406
Jr. Member
**

Karma: +1/-0
Offline Offline

Posts: 35


« Reply #20 on: February 23, 2019, 12:07:29 PM »

Thanks prj.
I've located KRKTE and TVUB so I changed injectors with success. Smiley
It has slight better responce in higher loads now.

But the mentioned behavior is still same. Until 4k RPM it's running at 14,5 AFR and above 4k RPM 10,5 AFR.

I will try to increase values in KFURLE at VTC ON regions. I hope that won't cause overfueling at part throttle when VTC is ON.

Thanks

Logged
prj
Hero Member
*****

Karma: +359/-78
Offline Offline

Posts: 3923


« Reply #21 on: February 24, 2019, 06:23:43 AM »

You need to log at least lambda request.
Most likely it's closed loop until 4k and after 4k it's in BTS.

Waste of time without logging.
Logged
MasterJJ406
Jr. Member
**

Karma: +1/-0
Offline Offline

Posts: 35


« Reply #22 on: February 24, 2019, 02:42:47 PM »

Adding more with KFURLE (about 20%) haven't solve anything (AFR 14,5).
Thanks for tip...I am thinking about BTS too, because I observed AFR switch about 3700RPM.

I see fueltrims up to this RPM at WOT in my logs so it could be due to close loop.
But I don't understand why?.... if my LAMFA= lambda < 1 and throttle above 60%.

I thought that I can set right WOT fueling without advanced logging. I have to invest more time to better log, but I think my wife is gonna kill me already Cheesy
Maybe I will do quick test and set KFFDLBTS at lower RPM to see if the switch in AFR become earlier.

thanks


Logged
MasterJJ406
Jr. Member
**

Karma: +1/-0
Offline Offline

Posts: 35


« Reply #23 on: March 04, 2019, 12:32:38 PM »

just posting result from quick test… BTS is not responsible for this.
I also remember that without SC I run with 12,6 AFR at all RPM range during WOT.

I have mainly only 2 problems:
1. Lean AFR during WOT at lowRPM - Leaving it for a moment until I can better log because I don't have Idea how to fix that.
2. Throttle cut while part throttle under boost.

(2.) From what I learned: from pedal -> KFPED -> torque request -> KFMIRL -> load value -> KUMSIRL -> massflow -> KFWDKMSN -> Throttle angle
But with belt driven SC it gives me BOOST at this open level. So it calculates back torque with higher actual load thru KFMIOP resulting throttle cut.

thinking about lowering WDKUGDN values, but not sure if this could fix it.
For example: stock throttle angle at 2000 is 38%, from logs about 17%

Please correct me if I am wrong. thank you

Logged
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.016 seconds with 17 queries. (Pretty URLs adds 0s, 0q)