Pages: [1]
Author Topic: C:\Users\d\me7_95040.exe is not a valid Win32 application  (Read 501 times)
dclifford40
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 20


« on: January 09, 2019, 03:28:30 PM »

Hi, and thanks
http://nefariousmotorsports.com/forum/index.php?topic=5068.0title=
Im working with this page and a bench rig on a 8eo 909 518af spare Audi ECU of unknown origin, came with my daily when I bought it and was not original to that car,,some mechanic tried this ECU to get the car to run with bad coil wiring and blown fuse for the coils,,another story.
 
My bench rig pulls the base info from the ecu with Nef software, when I try to pull the full flash I get ;

Requesting security access.
Received unknown message during security negotiation. Security negotiation failed.

Immo Im guessing

working down through the instructions on the page above with cmd prompt, I got the me7_95040.exe loaded and tried the commands listed after I figured out my com port was 5

Box pops up and says ;
C:\Users\d\me7_95040.exe is not a valid Win32 Application

I followed the guide and applied B+ to pin 121,,and grounded pin 24 on the ecu,,for 3 seconds,,and 10 seconds

I understand I could have a bricked ecu,,but the pin 24 should put it in bootmode, and make it readable..
Im obviously not great with cmd
the me7_95040 version I have is 1.32  perhaps I should be using the 1.40

thanks for any help
Logged
dclifford40
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 20


« Reply #1 on: January 09, 2019, 03:42:30 PM »

more info
This is what I get from the nef software
0x92, System Supplier ECU Hardware Number: 0261207939
   0x94, System Supplier ECU Software Number: 1037363573
   0x91, Vehicle Manufacturer ECU Hardware Number: 0x0D, 8E0909018A  , 0xFF
   0x9B, Calibration Date: 8E0909518AF , 0001, 0x0300416F, 0x00000000, 0xF777, 1.8L R4/5VT    ,  G   
   0x9C, Calibration Equiment Software Number: 0x00000002

My cable and rig get the base,
I dont think this ecu has been modded
Logged
dclifford40
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 20


« Reply #2 on: January 09, 2019, 05:00:11 PM »

I tried V 1.40
Help screen opens, guess the thing is working
message i get in the cmd is,,whole string;
C:\Users\d\>ME7_EEPROM --OBD -r -p 5 95040.bin
ME7_EEPROM is not recognized as an internal or external command, operable program or batch program
I am going to try to flash a immo off file I found on another part of the forum,,lets see if that flies.


Logged
Risky
Full Member
***

Karma: +3/-0
Offline Offline

Posts: 92


« Reply #3 on: January 09, 2019, 06:45:39 PM »

Use me7_95040.exe --obd -r -p 5
Logged
nyet
Administrator
Hero Member
*****

Karma: +443/-62
Offline Offline

Posts: 10189


WWW
« Reply #4 on: January 09, 2019, 09:01:36 PM »

Please read the stickies.

http://nefariousmotorsports.com/forum/index.php?topic=11034.0title=
Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
dclifford40
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 20


« Reply #5 on: January 12, 2019, 10:30:39 AM »

Use me7_95040.exe --obd -r -p 5

I still get not a valid win32 application with that string,,but thanks
Logged
dclifford40
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 20


« Reply #6 on: January 12, 2019, 10:42:20 AM »


I had already read through that,,appreciate your help.
As a noob to cmd commands, I did not put the whole string together to make it work.
I managed to figure it out,,i extracted the eeprom file,,next baby step..edit out the immo,,and try to load it in the ecm
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.02 seconds with 18 queries. (Pretty URLs adds 0s, 0q)