Pages: [1]
Author Topic: Golf 4 1.8t AGU converted to ME7 - Main relay DTC  (Read 1175 times)
sda2
Newbie
*

Karma: +3/-0
Offline Offline

Posts: 18


« on: November 19, 2019, 04:24:07 PM »

Hello Nefmoto,
My ME7 swapped AGU is currently driving me crazy. I converted it to narrowband ME7 4B0906018B running 06A906032AR 0007 with an ARZ engine harness and all the needed sensors.

The car obviously lacks SAP and N80 valve, that's why I 11'd them in the ESKONF and set expected secondary air volume to 0. Postcat O2 sensor is 11ed as well.

Injector variables are set corresponding to the existing AGU injectors currently, so it's basically plug'n'play. Attached you have my binary for troubleshooting purposes, please don't use it for flashing as it might be bad.

After adapting the T10a from the chassis to T14 connector of the engine harness, moving over the fuel pump to pin 3 of the orange connector, I thought I can just call it a day, but the engine had no spark.

The DTCs I got were:

17925 - Main Relay (J271): Electrical Malfunction P1517 - 35-00 - -
17972 - Throttle Actuator (J338): Under-Voltage during Basic Setting P1564 - 35-00 - -

I isolated that to the missing 12V line at the ignition coils, fed to them via the J271 main ECU relay. I guess the TBA is unable to succeed because of the other DTC still present.

But still, after manually bridging relay pin 5 to ground, or even jumping the switched relay contacts, I couldn't get the DTC P1517 to disappear. All the wires from the ECU to the relay box are intact, I double checked that.

After looking around inside the ME7 funktionsrahmen, I discovered that there are different self diagnosing functions for the relay depending on the software.
And additionally there are two versions of the relay, one 4 pin and one 5 pin. 1J0906381(B)

Is it possible, that I don't have an electronic problem, but the 4B0906018B ME7 from a Passat running 06A906032AR software is just confusing the diag functions? Maybe it doesnt have the circuitry to drive the relay at all?
I found those Passat ECUs way cheaper on Ebay, as they are more common. Same flash, another 018B ME7: same result

I have no idea how to move on from here, maybe you have a hint for me. Smiley
Logged
BlackT
Hero Member
*****

Karma: +28/-16
Offline Offline

Posts: 647



« Reply #1 on: November 20, 2019, 12:00:09 AM »

AGU/AEB only have Fuel pump relay.  ARZ have one more relay. You need to add it in your car.
Power to relay go from "30"  and ourput go to pin 121 at ECU, and to coils
Relay is trigered by pin 21 on ECU

BDW, did you put 4 gap camshaft triger?

Edit: I didn't understand you, what ECU is in the car?


« Last Edit: November 20, 2019, 12:04:46 AM by BlackT » Logged
sda2
Newbie
*

Karma: +3/-0
Offline Offline

Posts: 18


« Reply #2 on: November 20, 2019, 01:42:23 AM »

Yes, I know that, and the additional ECU relay is part of the engine harness and sits right next to the SAP relay. Cross connection T2m is plugged in and feeds coils and pin 121.

I see battery voltage on coils and ECU pin 121 when manually bridging the relay or pulling the relays control pin (pin 21 on ECU) to ground.

The stock ECU was an M3.8.3 flashable over OBD (06A906018BB) and had cruise control, so I already had CAN to cluster, a clutchsensor and the double brake sensor installed.

Now I have a 4B0906018B ME7 narrowband unit installed with the firmware 06A906032AR from an ARZ engine. When jumping the relay, the engine starts and runs in limp mode because I cannot make a complete throttle body alignment.

I have the other trigger wheel laying here, but that shouldnt be a problem because I get the DTC while engine shut off.

Maybe someone could measure the resistance of the control circuit of the ECU relay? The resistor installed in mine is 1.1kOhm (brown,brown,black,red,brown,orange).

Relay resistance is 148Ohm, 171.3 the control circuit, and 1.1kOhm on the resistor.

Edit: What do I have to change to get rid of the ECU relay in code/tune, I don't see the importance of that relay tbh.
« Last Edit: November 20, 2019, 02:54:34 AM by sda2 » Logged
BlackT
Hero Member
*****

Karma: +28/-16
Offline Offline

Posts: 647



« Reply #3 on: November 20, 2019, 03:20:32 AM »

Put in 4B0 906 018B software, i yust wrote about that yesterday.
http://nefariousmotorsports.com/forum/index.php?topic=16987.0title=

Fell fre to ask if something is not clear
Logged
sda2
Newbie
*

Karma: +3/-0
Offline Offline

Posts: 18


« Reply #4 on: November 20, 2019, 03:59:10 AM »

But both of the ECUs are using the J271 main relay, and pinout is matching according to ELSA WD.

Bootrom version is matching as well between ARZ and APU. Output following:

Code:
C:\Users\...>ME7Check.exe VW_Golf_4_1.8T_ARZ_06A906032AR_0007_0261206436_1037352758.bin
==============================================================================
ME7Check v1.12 (c) mki, 06/2004-05/2012
Checking file VW_Golf_4_1.8T_ARZ_06A906032AR_0007_0261206436_1037352758.bin (size=524288)
Reading Version Strings...
-> Bootrom Version = 05.12
-> EPK = 42/1/ME7.5/3/4013.00//F21dz/Dst07g/260899/
-> Contents of ECUID data table:
   - '0261206436'         (SSECUHN)
   - '1037352758'         (SSECUSN)
   - '06A906032AR '       (VAG part number)
   - '0007'               (VAG sw number)
   - '1.8L R4/5VT     '   (engine id)
-> Contents of ECUID data table:
   - 'HW_MAN004'

-> No errors found. File is OK.   *********************


C:\Users\...>ME7Check.exe VW_Passat_1.8T_APU_4B0906018B_0261206050_1037350229.bin
==============================================================================
ME7Check v1.12 (c) mki, 06/2004-05/2012
Checking file VW_Passat_1.8T_APU_4B0906018B_0261206050_1037350229.bin (size=524288)
Reading Version Strings...
-> Bootrom Version = 05.12
-> EPK = 40/1/ME7.5/5/4017.00//PST_SER/DST_SER2//
-> Contents of ECUID data table:
   - '0261206050'         (SSECUHN)
   - '1037350229'         (SSECUSN)
   - '4B0906018B  '       (VAG part number)
   - '0004'               (VAG sw number)
   - '1.8L R4 5VT         '   (engine id)
-> Contents of ECUID data table:
   - 'HW_MAN004'

-> No errors found. File is OK.   *********************

I will try to find a matching definition file for 018B and flash back to APU software, but I doubt that it will work, as it needs main relay as well.
Logged
BlackT
Hero Member
*****

Karma: +28/-16
Offline Offline

Posts: 647



« Reply #5 on: November 20, 2019, 04:11:04 AM »

I have APU engine with 4B0 906 018 and it does not use ECM relay.
Try to upload original file to your ECU and see what will hapen.
Bdw. It looks like this method for same bootloader version work only on 1Kb ECUs, as I said I am still pionir and I am also in learnig procesa. So don't mind me if some informations are not 100% true
Logged
sda2
Newbie
*

Karma: +3/-0
Offline Offline

Posts: 18


« Reply #6 on: November 20, 2019, 05:34:26 AM »

Okay, I just found out, that there are two kind of APU engines, one without J271 and one with it, the change was 05/1999.

So you have 4B0906018B running without a relay? Then this seems to be the older version and missing the relay output. Do you have a definition file for that version, like an XDF or OLS?
Logged
BlackT
Hero Member
*****

Karma: +28/-16
Offline Offline

Posts: 647



« Reply #7 on: November 20, 2019, 05:56:04 AM »

No I(my friends) have A4 APU 4B0 906 018
And TT 8N0 906 018 AB   both of  them are W/O ECM relay
For both of them you have def here on forum
http://nefariousmotorsports.com/forum/index.php?topic=12771.0;topicseen
Here is one and other I can upload or you can find it
Logged
sda2
Newbie
*

Karma: +3/-0
Offline Offline

Posts: 18


« Reply #8 on: November 20, 2019, 06:27:10 AM »

The original file on the ECU was 4B0906018B 0004, the one you suggest is without B at the end and revision 0001.

I will try the file anyways. Maybe it'll work.
« Last Edit: November 20, 2019, 06:28:52 AM by sda2 » Logged
sda2
Newbie
*

Karma: +3/-0
Offline Offline

Posts: 18


« Reply #9 on: November 20, 2019, 06:30:47 AM »

Here is the WD I was refering to, APU engine from Passat with J271
Logged
BlackT
Hero Member
*****

Karma: +28/-16
Offline Offline

Posts: 647



« Reply #10 on: November 20, 2019, 07:58:42 AM »

8E0 418 AB with original file (no ECM relay DTC)


And with file from ecu that in original have ECM relay
Logged
sda2
Newbie
*

Karma: +3/-0
Offline Offline

Posts: 18


« Reply #11 on: November 21, 2019, 12:47:41 AM »

Engine runs without DTC! Thank you very much!

Now I only have to find out why my ECUs screw up the relay check. We successfully put another 018B into a TT APX, that also has the relay and its working there.

Is there a way to supress the relay check by configuration value changes?
Logged
sda2
Newbie
*

Karma: +3/-0
Offline Offline

Posts: 18


« Reply #12 on: January 16, 2020, 04:13:00 AM »

I disassembled the 4B0906018 SW0001 and verifed that the main relay diagnosis is completely missing from the program code.

I will try to "nop" the 32AR firmware at the subroutine call and report back.

And I modified a second 6018B ecu where I added the HR output signal connection.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.028 seconds with 17 queries. (Pretty URLs adds 0s, 0q)