Pages: [1]
Author Topic: 8E2910560A - CSpin needed  (Read 413 times)
bamofo
Full Member
***

Karma: +20/-0
Offline Offline

Posts: 221


« on: February 13, 2020, 06:09:36 PM »

Working on an 07 Audi B7 S4 and im having a hard time getting the eeprom off the ECU. Normally it figures out the CSpin on its own... This 8e2 ECU is giving me a hard time though.

Can someone help with what the pin is i should be putting in? I tried P6.0 till P6.7 where it errored out after that in the EEPROM tool.

Thanks in advance.
Logged
gremlin
Sr. Member
****

Karma: +87/-6
Offline Offline

Posts: 299


« Reply #1 on: February 14, 2020, 09:50:39 AM »

Pin is P6.3
Can your eeprom tool work with ST10C175 MCU ID value (ID=0x1143) ?
It is different from ID of ะก167CS MCU
Below is eeprom read log of this type ECU.
Att! EEprom read tool was patched to recognized ST10 ID!!

me7eeprom1 --bootmode 95160 --CSpin P6.3 -r -p1 eeprom.bin
ME7_EEPROM v1.40
COM: 1, Baud Rate: 10400
Memory type: 95160, size: 2048
Chip Select pin: P6.3
Opening COM1 ... OK
Starting Boot_mode ... uC ID response 0xD5 ... OK
Sending Loader + MonitorCore ... MonitorCore successfully launched
Reading IDCHIP ... 0x1143: C167CS ... OK
Initializing registers ... OK
Sending EEPROM driver ... OK
Configuring SPI Interface ... OK
Checking EEPROM Status Register ... 0x0080
Reading EEPROM ... OK
File saved
Closing COM1

 
Logged
bamofo
Full Member
***

Karma: +20/-0
Offline Offline

Posts: 221


« Reply #2 on: February 14, 2020, 10:42:00 AM »

worked with Gremlin and got the eeprom. Thanks.
« Last Edit: February 19, 2020, 11:23:56 AM by bamofo » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.013 seconds with 18 queries. (Pretty URLs adds 0s, 0q)