Pages: [1]
Author Topic: Failed to read test echo from ftdi device.  (Read 1280 times)
dalazybastard
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 6


« on: April 28, 2020, 10:00:49 PM »

Hello all,

When trying to connect to an ECU in the car, the message "Failed to read test echo from the FTDI device" occurs at any baud rate or init.

I've spent quite a large time trying to understand why this happens.

The cable I am using the obdlinksx:

https://www.amazon.com/ScanTool-OBDLink-USB-Professional-Diagnostics/dp/B005ZWM0R4

*I also have another cable from a company that specializes in the tuning of the cars I have tried to read. Funny thing is that cable is just a relabeled obdlinksx (the FTDI chip is the same: ft230xq; I have not seen any information against or for this chip with Nemoto)*

**I also have a genuine VCDS hex-net but understand that does not function with Nemoto

***Both cables can use other software to connect to the ECU on the cars, VCDS connects flawlessly with the hexnet so not an OBD port issue.

I have verified that the drivers are installed from the FTDI website.

I have attached screenshots of the device manager and Nemoto screens.

When connecting I have the key in and ignition on. The cars/ecus I have tried to connect to are B5 S4(Various ECUs and cars), B5 A4 2001 (M and CH ecu don't know the numbers off the top of my head), and B6 A4 (8E0909518AF and 8E0909518AK) all to no avail.

I have tried restarting the Nemoto software, unplugging the lead, removing the fuses for instruments, unplugging the cluster, and redownloading from the software.

Please advise and thank you in advance.

Logged
aef
Hero Member
*****

Karma: +55/-37
Offline Offline

Posts: 1320


« Reply #1 on: April 28, 2020, 10:36:07 PM »

Where is this ME7.9.. Text coming from? Have you modified the cable/firmware/driver somehow?

Please download mprog here and read and parse the information from your ftdi cable:
http://nefariousmotorsports.com/forum/index.php?topic=3088.msg31072#msg31072

make sure to save is before you change anything.
show driver details of this cable in device manager. Should be ftdi 2.12.28 something?!

VCDS cable should work too with VCP Mode drivers. Also well described somewhere in here.
Logged
Auriaka
Full Member
***

Karma: +17/-2
Offline Offline

Posts: 113



« Reply #2 on: April 28, 2020, 10:39:27 PM »

I have used a hex-can usb just fine with nefmoto... my galeto works as well which is hilarious.

I would definitely figure out what’s up with your cable and check yours drivers.
Logged
dalazybastard
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 6


« Reply #3 on: April 29, 2020, 02:18:21 AM »

The ME7.9..... comes from the cable from said tuner. What has been done to it is beyond me. This tuner has its own software that reads and writes files, however, these files are not .bin files rather .mtz and have do not pass checksums in ME7check for a known good file.

The OBDLink SX appears as such "OBDLink SX" when plugged into Nefmoto. Still does the same issues. I just took the screenshot when using the tuner's cable.

I have downloaded the mprog and understand what it wants to do, but when I read and parse, even with just reading prior it gives me the error of "ERROR - Read EEPROM failed Device 0". Which leaves me at a standstill.

Also, when opening the file "Proper English galletto.rar" with the hex editor, the line looks like this:

00249E90  32 9C 19 74 A2 5A 9A 58 A4 E8 E5 25 D9 2E 39 91     2œ.t¢ZšX¤èå%Ù.9‘

When I try modifying the cable's serial number to that of Galletto's when I try to program it, mprog returns the message "device not found"

Attached are screenshots of the driver details in the device manager.

As for VCDS hex-can, I don't have that cable and am certain I could get that cable to work. I have the hex-net cable which is the wifi capable cable that does not have a dumb mode in VCDS and is only mentioned in one thread linked below.

http://nefariousmotorsports.com/forum/index.php?topic=12019.0
« Last Edit: April 29, 2020, 02:30:33 AM by dalazybastard » Logged
aef
Hero Member
*****

Karma: +55/-37
Offline Offline

Posts: 1320


« Reply #4 on: April 29, 2020, 03:03:25 AM »

you have to edit galletto exe not the rar/zip

but this will not work as far as mprog refuses to work with your cable(s)

i dont know this kind of cable. maybe human error, maybe cable.

please provide a picture of mprog after you hit devices -> scan

try this https://www.ftdichip.com/Support/Utilities.htm#FT_PROG
Logged
dalazybastard
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 6


« Reply #5 on: April 29, 2020, 12:24:42 PM »

So I have attached the Mprog scan, and "read and parse". Also the FTDI-prog "scan and parse" returns the serial number.

I've extracted the .rar file and edited the hex for the EOBD1260.exe to use my serial number from FTDI PROG.

Now when I went out to the car to read the ECU data using the saved EOBD1260.exe file, Galletto returns interface not found. and when I try to read ecu it just quits the application. I am thinking this is a USER error issue.





« Last Edit: April 29, 2020, 12:39:17 PM by dalazybastard » Logged
MusicalSponge
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 1


« Reply #6 on: September 19, 2021, 09:18:20 AM »

Did anyone ever get an update for this? Newbie here and having the same problem with the same cord. I'm guessing they're just junk, but it'd be nice to not have to wait on another cable.
Logged
denniss112
Newbie
*

Karma: +0/-2
Offline Offline

Posts: 16


Audi TT 99' | 180+HP FWD


« Reply #7 on: September 19, 2021, 02:41:47 PM »

I had this with an approved Ross-Tech cable on my MK1 TT. I bought a MPPS V18 cable for 30 Euros on AE and I can now read,write and checksum with that software. Its realy easy to use and the drivers are included.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.018 seconds with 17 queries. (Pretty URLs adds 0s, 0q)