Pages: [1]
Author Topic: Car won’t start after reading ECU  (Read 1004 times)
bikemaker
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 7


« on: January 09, 2021, 07:07:11 PM »

I read my ECU for the first time and now my car won’t start. I see the immobilizer symbol briefly before cranking engine. I’ve a 2003 Allroad, a laptop, USB cable with FTD232RL and VCDS light and also VAG COM Commander that I’ve used before. I’ve read the noobie stuff, the Wikis and instructions on using Nefmoto, Me7check and believe everything worked as it should. I saved the downloaded flash, verified its checksum and even tried writing it back to the ECU. My car cranks but won’t start What do I do now? Thank you
Logged
xXxCryxXx
Full Member
***

Karma: +1/-5
Offline Offline

Posts: 64


« Reply #1 on: January 09, 2021, 07:16:16 PM »

I read my ECU for the first time and now my car won’t start. I see the immobilizer symbol briefly before cranking engine. I’ve a 2003 Allroad, a laptop, USB cable with FTD232RL and VCDS light and also VAG COM Commander that I’ve used before. I’ve read the noobie stuff, the Wikis and instructions on using Nefmoto, Me7check and believe everything worked as it should. I saved the downloaded flash, verified its checksum and even tried writing it back to the ECU. My car cranks but won’t start What do I do now? Thank you
Why did you say in your main Post after reading when you write your Ori file back on ECU?

X-Boost Performance

Logged
bikemaker
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 7


« Reply #2 on: January 09, 2021, 07:24:04 PM »

Because it would not start after initial reading and saving the binary file. Everything looked good I had the successful pop up message box. I disconnected turned off the key for half minute and the tried starting the engine After this I tried writing the file back to the ECU with same results - no start Sad
Logged
nyet
Administrator
Hero Member
*****

Karma: +514/-109
Offline Offline

Posts: 11369


WWW
« Reply #3 on: January 09, 2021, 07:28:34 PM »

Please provide the P/N and any codes

http://nefariousmotorsports.com/forum/index.php?topic=981.0title=
Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
Marty
Hero Member
*****

Karma: +178/-255
Offline Offline

Posts: 1747


« Reply #4 on: January 09, 2021, 09:22:18 PM »

programming not completed code, it happens with some software versions i guess they don't exit programming mode properly . theirs a whole thread about it and how to fix it. you could also flash a r box file to fix it too
 
Logged

bikemaker
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 7


« Reply #5 on: January 11, 2021, 06:19:23 AM »

I tried again unsuccessfully by disconnecting the battery from vehicle and also using VCDS and clearing error codes.

The ECU information:
-> Contents of ECUID data table:
   - '0261208288'         (SSECUHN)         
   - '1037368391'         (SSECUSN)         
   - '4Z7907551S  '       (VAG part number)
   - '0020'               (VAG sw number)   
   - '2.7L V6/5VT    '    (engine id)       
-> Contents of ECUID data table:
   - 'HW_MAN004'                           


-> No errors found. File is OK.   *********************

I was getting the error "programming not completing code". I'm not sure what thread explains how to fix this but I'll keep looking. I'm not sure if this is software or a hardware glitch but I've tried to get past it. thank you for your help
Logged
bamofo
Sr. Member
****

Karma: +26/-0
Offline Offline

Posts: 313


« Reply #6 on: January 11, 2021, 01:02:00 PM »

Grab the stock file and do a diff write. Key off/on, Diff write one more time and key off. Should start after that.

With Nefmoto at least.
Logged
nyet
Administrator
Hero Member
*****

Karma: +514/-109
Offline Offline

Posts: 11369


WWW
« Reply #7 on: January 11, 2021, 01:50:23 PM »

I'm not sure what thread explains how to fix this but I'll keep looking.

I literally linked it in my post above.
Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
bikemaker
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 7


« Reply #8 on: January 11, 2021, 04:00:44 PM »

Woo hoo! I got lucky! I found this thread
http://nefariousmotorsports.com/forum/index.php?topic=6719.0
and I edited my original binary, I also added editing out my SAI and rear O2 sensors but that file didn't load. so I tried just the single byte edit and that file loaded and the car started but I had no throttle by wire. I went back and forth several times finally succeeding in loading my original binary and clearing the DTC's. So it appears all is fine again but I still need to delete my SAI and rear O2's. When I feel I can brave another session I'll try again for the SAI deletes. Thank you Tony and all else for your time and attention. Smiley
Logged
nyet
Administrator
Hero Member
*****

Karma: +514/-109
Offline Offline

Posts: 11369


WWW
« Reply #9 on: January 11, 2021, 04:18:40 PM »

Woo hoo! I got lucky! I found this thread
http://nefariousmotorsports.com/forum/index.php?topic=6719.0
and I edited my original binary, I also added editing out my SAI and rear O2 sensors but that file didn't load. so I tried just the single byte edit and that file loaded and the car started but I had no throttle by wire. I went back and forth several times finally succeeding in loading my original binary and clearing the DTC's. So it appears all is fine again but I still need to delete my SAI and rear O2's. When I feel I can brave another session I'll try again for the SAI deletes. Thank you Tony and all else for your time and attention. Smiley

Do NOT do a read unless you do that patch.

Highly recommend using a non-S binary (preferred), or patching your file. You should not have lost dbw, that makes no sense.
Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
bikemaker
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 7


« Reply #10 on: January 12, 2021, 11:01:43 PM »


Reviewing my log files it appears I shot myself in my own foot. From the log file I determined I should have turned the ignition off, instead I attempted to READ DTC’s and got an error code. What followed was a failure of my engine to start.

“09/Jan/2021 04:32:28.276: USER: The ECU is in programming mode, and needs the ignition turned off to reset.
If this does not end programming mode, the ECU likely believes the flash memory is not programmed correctly.
09/Jan/2021 04:32:28.296: USER: Reading all ECU DTCs failed.”

When I tried to write the original file I got the following DTC’s which I am certain is why the drive by wire circuits were shut down.

“P0602 Module programming error, P0562 System voltage low, P2128 Unknown DTC, P0123 Throttle/pedal position sensor, P0223 Throttle/pedal position sensor and P2123 Unknown DTC”

All is currently well and I am a little more confident in trying once again to kill the SAI and O2 monitors. Launch control sounds like something I would be interested in. And Tony I am still uncertain if you are saying I should use a 4Z7907551R binary as a base flash instead of –S??? Thanks everyone

Logged
nyet
Administrator
Hero Member
*****

Karma: +514/-109
Offline Offline

Posts: 11369


WWW
« Reply #11 on: January 14, 2021, 01:59:29 AM »

And Tony I am still uncertain if you are saying I should use a 4Z7907551R binary as a base flash instead of –S??? Thanks everyone

Yes, you should use -R instead of -S or perform the patch as described.
Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.021 seconds with 18 queries. (Pretty URLs adds 0s, 0q)