Pages: [1]
Author Topic: DSG DQ250 MTX box on S3 8L DIY build, G195/G196 intermittent, abs off works  (Read 5391 times)
warsuperior
Newbie
*

Karma: +0/-2
Offline Offline

Posts: 8



I have Audi S3 8L with Ignitron ecu and I changed from Golf R 2011 the MTX DSG DQ250 gearbox to it.
Otherwise car works ok but when speed goes over 60km/h the car disengage gear and puts it back on after speed drops.
VCDS gives codes
7106 -  Transmission Output Speed Sensor (G195): No Signal
        P0722 - 000 -   - - Intermittent
18201 -  Transmission Output Speed Sensor 2 (G196): No Signal
        P1793 - 000 -   - - Intermittent

But logging VCDS shows there is still info from the sensors.
ABS fuse off the car can be driven without limit but having huge ass ! on screen and beeps and no abs is no fun. Also box dont change so smoothly.

I thought my mecha is broken so I switched to another but no, same error.
I thought the speed ring for G195 is busted and switched it too, same error still.

ABS sensors give all same readings so it looks like they are ok, alltho they are old 3 of them years old but they work.

ABS fuse off I can drive car normally and all works.
My car has MK20 abs not newer MK60
Ignitron has features to emulate MK60 info but it did not help.

Can this be somehow disable so it wont check abs speed or something?

I am out of ideas unless I just do switch to abs and drive with switch off below 60kmh and above turn on, and disable abs so I can drive faster. And maybe put cluster wire from abs to ground so it wont alarm(dont know if possible or which wire.

Any ideas or help?
Logged
GianniNOS
Jr. Member
**

Karma: +2/-0
Offline Offline

Posts: 36



this error are referred to speed sensors in gear box for 1st and 2nd coaxial primary input ...
Logged
warsuperior
Newbie
*

Karma: +0/-2
Offline Offline

Posts: 8



I know it refers to them but they are not broken since with mecha change, nothing changed. Also speed ring was changed, still same error.
For some reason the DSG seems to not understand ABS signal, or possibly it dont undrstand because it has no ESP on it.

Im wondering is there way to program the DSG to disable the checking of ABS and rely on G195 speed
Logged
GianniNOS
Jr. Member
**

Karma: +2/-0
Offline Offline

Posts: 36



may be gear ratio are different, so there are incongruence between speed from tcu and speed from abs ...
Logged
terok
Full Member
***

Karma: +7/-3
Offline Offline

Posts: 123



I can confirm from experience, that DSG goes bonkers if speed via CAN (ABS) and internally calculated speed are not close enough.
This is also why you cannot use GPS speed in cars with retrofitted DSG (or you can use it for dash only).

Logged
Techguy
Jr. Member
**

Karma: +2/-8
Offline Offline

Posts: 48



try changing dsg firmware, i have fitted multiple mechatronics into multiple dq250s and i find that sometimes the software doesn't like the ratios/ input from primary / secondary shaft.

recently i did a manual to dsg conversion on a s3 8p, just added the can hi/low/kline/neutral switch/power and its working perfectly, while another car "tt" i swapped in a golf r dsg and it didn't like the abs signal and was dropping second gear, because i have multiple dq250 firmwares from vr read/previous backups and i can get the original frf/sgo files and flash that, i just kept swapping all the revisions until it worked perfectly

now i know this may not apply to your situation as you have fitted it into a 8l, if it is a abs issue, swap out the abs unit to an 8p one.
Logged
fukenbroken
Hero Member
*****

Karma: +156/-14
Offline Offline

Posts: 1246


mk4 1.8T AUM



Hey
Im in the same boat for now - mk4 with teves mk20 abs
Stuck in another city where i came to swap dsg and for now it drives the same - drops the gear after 60 kmh no matter ehat im doing dtc19143 came up with 'unexpected gear disengagement'
Ive change diagnose maps and g195/g196 sensor dtcs gone but it still drops the gear after 60kmh
Is there any solution?
Sw is 02E300051C
Logged
prj
Hero Member
*****

Karma: +554/-171
Offline Offline

Posts: 4870



Are the gear ratios actually correct in the sw?
Logged

PM's will not be answered, so don't even try.
fukenbroken
Hero Member
*****

Karma: +156/-14
Offline Offline

Posts: 1246


mk4 1.8T AUM



Gearbox comes from the 2009 scirocco 2.0 tfsi
Mechatronic unit never changed and pn corresponds to gearbox
Problem temporary solved with pulling out abs fuse as an op said

There is also a dtc with impossible abs signal stored in gearbox ecu, but its common with mk20 cars
And ive seen once a3 8l running 02E300014Q without any issue with mk20 aswell

Logged
AndreyBZ
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 5



Its not an issue from Gear ratios.

Unplug ABS module and do a test, and tell me.
Logged
fukenbroken
Hero Member
*****

Karma: +156/-14
Offline Offline

Posts: 1246


mk4 1.8T AUM


« Reply #10 on: November 29, 2021, 08:00:09 AM »

As i said earlier, problem disappears with unplugged abs module
Logged
ARDIO_RU
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 2


« Reply #11 on: November 18, 2022, 05:51:37 AM »

Hello!

Do you resolve this problem?

I have similar trouble on Golf Plus DSG-6, but I haven't any DTCs in ECM, TCM, ABS.

Shifts 2-3, 3-4, 4-5 are very-very late in automatic mode (D).

But If I remove ABS fuse - I have good shifts.
Logged
BlackT
Hero Member
*****

Karma: +71/-32
Offline Offline

Posts: 1261



« Reply #12 on: November 18, 2022, 08:15:44 AM »

Your dash is using simgal from vss or from can-bus to show speed?
Logged
Breacking
Jr. Member
**

Karma: +0/-5
Offline Offline

Posts: 27


« Reply #13 on: November 18, 2022, 11:46:24 AM »

Hi all. I own an Audi S3 8L with a dsg dq250 installed. I have mk20 + esp. It works well. On the forums I saw information that the DSG will work with mk20 + esp or mk60
Logged
ARDIO_RU
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 2


« Reply #14 on: November 20, 2022, 04:29:34 AM »

Your dash is using simgal from vss or from can-bus to show speed?

Dash using signal from ABS via CAN.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.022 seconds with 17 queries. (Pretty URLs adds 0.001s, 0q)