Pages: 1 2 3 [4]
Author Topic: Free ME7 Logging with VehiCAL Logger  (Read 21866 times)
prj
Hero Member
*****

Karma: +1026/-435
Offline Offline

Posts: 5881


« Reply #45 on: December 29, 2023, 07:44:07 AM »

Instead of screenshots copy-paste the text...

From output results:
1. At least one of these parameters is completely broken on the interface:
P1_MAX
P3_MIN
P4_MIN
FIVE_BAUD_MOD

So slow init or double slow init is not going to work unless interface author fixes it.

2. Looking at fast init, ECU needs security access to change baudrate, looks like there's a regression in the tool due to recent refactoring, that it is not detecting that, normally it should do it automatically.
Try the beta:
https://download.vehical.net/logger/LoggerInstallBeta.exe
Logged

PM's will not be answered, so don't even try.
Log your car properly.
Blazius
Hero Member
*****

Karma: +89/-40
Offline Offline

Posts: 1278



« Reply #46 on: December 31, 2023, 04:00:48 AM »

Instead of screenshots copy-paste the text...

From output results:
1. At least one of these parameters is completely broken on the interface:
P1_MAX
P3_MIN
P4_MIN
FIVE_BAUD_MOD

So slow init or double slow init is not going to work unless interface author fixes it.

2. Looking at fast init, ECU needs security access to change baudrate, looks like there's a regression in the tool due to recent refactoring, that it is not detecting that, normally it should do it automatically.
Try the beta:
https://download.vehical.net/logger/LoggerInstallBeta.exe


Well finally I got it working.


Using the beta, I was able to initialize/connect/log.

So currently this is how it goes: connect using auto/auto baud. It will fail on fast init, go to slow, it will connect then timeout after 2 seconds or so( I can hear the cluster "clicking" too like ME7logger).
Then without turning ignition off connect on auto again(this is the procedure I have to do with me7logger too, connect on 0x00 fail cause of wrong response then connect with slow0x01) and it will connect with fast 0x10 and run on correct baud.
After this it works perfect.

As per tool and my application I was a little bit surprised it didnt parse all the measurements from the (public) A2l available for this ecu - 018CM 0008 only the same ones ME7logger creates basically.
Would've been nice.
Logged
prj
Hero Member
*****

Karma: +1026/-435
Offline Offline

Posts: 5881


« Reply #47 on: December 31, 2023, 04:11:43 AM »

So currently this is how it goes: connect using auto/auto baud. It will fail on fast init, go to slow, it will connect then timeout after 2 seconds or so( I can hear the cluster "clicking" too like ME7logger).
Then without turning ignition off connect on auto again(this is the procedure I have to do with me7logger too, connect on 0x00 fail cause of wrong response then connect with slow0x01) and it will connect with fast 0x10 and run on correct baud.
After this it works perfect.
As said before it means your cable does not support one of the parameters, so it can not communicate on KW1281.
Otherwise it would just work.

Quote
As per tool and my application I was a little bit surprised it didnt parse all the measurements from the (public) A2l available for this ecu - 018CM 0008 only the same ones ME7logger creates basically.
Would've been nice.
You can create your own custom list from the A2L:
https://docs.vehical.net/logger_custom
Or in your case you can also try the VAG KWP - Advanced paid protocol (but only if fast init actually works directly with your cluster).

The free protocol is literally the same variables as ME7Logger because ME7Info was used to dump all the bins and then that data used.
It's also why it's free.

Full A2L logging is for newer ECU's (that support fastinit directly) in VAG KWP - Basic.
If you want to add some a2l, you do that the same way as with ME7Logger using a custom measurements file.
Logged

PM's will not be answered, so don't even try.
Log your car properly.
Spen Holder
Jr. Member
**

Karma: +1/-3
Offline Offline

Posts: 31


« Reply #48 on: January 03, 2024, 01:24:55 AM »

Does the paid version work for vag med9 ecus? I have a mk6 golf r and before I have any tuning done I would like to log the car for a baseline. Plus side is I still have my tectrix cable from my old Subaru days, so that's a plus!
Logged
prj
Hero Member
*****

Karma: +1026/-435
Offline Offline

Posts: 5881


« Reply #49 on: January 03, 2024, 02:01:05 AM »

Does the paid version work for vag med9 ecus? I have a mk6 golf r and before I have any tuning done I would like to log the car for a baseline. Plus side is I still have my tectrix cable from my old Subaru days, so that's a plus!
Yes...
https://docs.vehical.net/logger_protocols
Logged

PM's will not be answered, so don't even try.
Log your car properly.
Spen Holder
Jr. Member
**

Karma: +1/-3
Offline Offline

Posts: 31


« Reply #50 on: January 04, 2024, 12:58:28 AM »

Awesome, I ended up buying a tune first... Stupid, I know but I couldn't help myself. Friday is payday and this is the first on the list. This community here is awesome. Thanks for everything you guys do!   
Logged
unodosi
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 6


« Reply #51 on: April 08, 2024, 12:45:16 PM »

Hey PRJ, replied here from the Volvo ME7 thread as to not clog that thread with side questions.

Your logger supports ME9 but what protocol is it under? 

I don't suppose the "VAG ME7 C167 K-Line (Free) - Advanced" one works? lol.
Logged
prj
Hero Member
*****

Karma: +1026/-435
Offline Offline

Posts: 5881


« Reply #52 on: April 08, 2024, 03:11:09 PM »

Hey PRJ, replied here from the Volvo ME7 thread as to not clog that thread with side questions.

Your logger supports ME9 but what protocol is it under?  

I don't suppose the "VAG ME7 C167 K-Line (Free) - Advanced" one works? lol.

No, that one does not work.
All the Volvo stuff (ME7, ME9) is under Volvo - Advanced and it's a paid protocol.

You can do an init in your car without having to pay for anything to check if I have def on server and what variables are available.
Should work fine with DiCE unit as it is J2534 compatible.
Logged

PM's will not be answered, so don't even try.
Log your car properly.
unodosi
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 6


« Reply #53 on: April 08, 2024, 04:40:44 PM »

Ahhh, I must admit the price is a little steep for my taste just to get a truly barebones datalog that spits out a xml files so I can toss it into datazao and give it a look.

I have vida and think(?) I can extract the logs from it but it is annoying, not XML and running on a brick of a laptop that can't connect to online lol.

That said, I will 100% remember your product for when I am ready to truly start messing with things. I am still trying to just learn right now I can do whatever I do properly.

Logged
prj
Hero Member
*****

Karma: +1026/-435
Offline Offline

Posts: 5881


« Reply #54 on: April 08, 2024, 04:59:51 PM »

Ahhh, I must admit the price is a little steep for my taste just to get a truly barebones datalog that spits out a xml files so I can toss it into datazao and give it a look.

I have vida and think(?) I can extract the logs from it but it is annoying, not XML and running on a brick of a laptop that can't connect to online lol.

That said, I will 100% remember your product for when I am ready to truly start messing with things. I am still trying to just learn right now I can do whatever I do properly.

VIDA has a limited variable selection, this is a RAM logger with all the variables in the ECU available. It has more than 100x the variable count compared to VIDA.
Not even close to comparable. It's like comparing a Dacia to a Lamborghini.

Also, no XML here, CSV.
Logged

PM's will not be answered, so don't even try.
Log your car properly.
Jozua
Newbie
*

Karma: +1/-1
Offline Offline

Posts: 23


« Reply #55 on: April 09, 2024, 02:15:24 AM »

Tactrix open port works great
Logged
Pages: 1 2 3 [4]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.02 seconds with 16 queries. (Pretty URLs adds 0s, 0q)