Pages: 1 ... 3 4 [5]
Author Topic: P0602/P1681 Control Module Programming Not Finished - Workaround for ME7.1.1/7.5  (Read 10656 times)
dragon187
Jr. Member
**

Karma: +0/-5
Offline Offline

Posts: 48



Where are you from?
Maybe someone is near by you who can help?

This is a can ecu and it should be write over can..

NEF Tool is kline?..

Regards
Logged
nyet
Administrator
Hero Member
*****

Karma: +441/-62
Offline Offline

Posts: 10084


WWW

Where are you from?
Maybe someone is near by you who can help?

This is a can ecu and it should be write over can..

NEF Tool is kline?..

Regards

yes, NEF is kline only
Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
brodway2800
Newbie
*

Karma: +0/-1
Offline Offline

Posts: 14



I will try over can and will let know about progress.
Thanks for advise Smiley
Im from Poland but i live in Scotland, in a town where no one does such things. Sending my ecu to someone will not gain any experience for me.
I like sort out things by myself, even if it will take a lot of time.
« Last Edit: January 17, 2018, 03:00:24 AM by brodway2800 » Logged
brodway2800
Newbie
*

Karma: +0/-1
Offline Offline

Posts: 14



Same thing over CAN. Can read it but i cant flash it in the car or on the bench. FGtech says:
 silentkey error
wake ERASE ERR.
 Sad Sad Sad Sad Sad Sad Sad

Will virginising eeprom help ??
« Last Edit: January 17, 2018, 06:56:18 AM by brodway2800 » Logged
dragon187
Jr. Member
**

Karma: +0/-5
Offline Offline

Posts: 48



Fgtech not work (clone) on this ecu..

Take ori Mpps can driver or
Kess v2 can driver

Try different speeds

Regards
Logged
brodway2800
Newbie
*

Karma: +0/-1
Offline Offline

Posts: 14



Virgin eprom helped, car started straight away
Logged
Marty
Hero Member
*****

Karma: +141/-100
Offline Offline

Posts: 1414



Virgin eprom helped, car started straight away
Glad its set
Logged

Crushing
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 2



What am I doing wrong? I am still very new at this but I tried full read with nefmoto on my 2004 a6 2.7t, the. It wouldn't start and was throwing codes po602, p1681 and p18089 programming not finished. After reading several posts on the issue I tried full read several times a long with full write/flash, delete codes, not deleting codes, cycling key, disconnecting battery, writing the 4z7907551r .bin instead of stock 4z7907551s .bin with no luck on either file. I don't want to brick my ecu as I haven't had luck with getting it in boot mode with galletto 1260 yet either. I started looking through the hex editor in tuner pro for this threads fix but after an hour of searching I felt like an idiot thinking there is probably a hex search option that would find it quicker. Please tell me what I'm doing wrong and point me in the right direction.

Sent from my SM-G930V using Tapatalk

Logged
nyet
Administrator
Hero Member
*****

Karma: +441/-62
Offline Offline

Posts: 10084


WWW

affects 8N0906018CJ
Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
nyet
Administrator
Hero Member
*****

Karma: +441/-62
Offline Offline

Posts: 10084


WWW

What am I doing wrong? I am still very new at this but I tried full read with nefmoto on my 2004 a6 2.7t, the. It wouldn't start and was throwing codes po602, p1681 and p18089 programming not finished. After reading several posts on the issue I tried full read several times a long with full write/flash, delete codes, not deleting codes, cycling key, disconnecting battery, writing the 4z7907551r .bin instead of stock 4z7907551s .bin with no luck on either file. I don't want to brick my ecu as I haven't had luck with getting it in boot mode with galletto 1260 yet either. I started looking through the hex editor in tuner pro for this threads fix but after an hour of searching I felt like an idiot thinking there is probably a hex search option that would find it quicker. Please tell me what I'm doing wrong and point me in the right direction.

This thread is about patching your the ECU code so it doesn't cause the problem.

The flashing thread here:
http://nefariousmotorsports.com/forum/index.php?topic=981.0title=
covers more general info

Both threads contain extensive answers to your questions, you'll have to be more specific if you want something else.

In short, you will not be able to fix p1681 without moving to a ECU bin that doesn't suffer the problem, or by hand patching ASM.

That said, flashing the R file should have worked. You may have to it in flash boot mode if the ECU is bricked.

« Last Edit: November 09, 2018, 12:30:37 PM by nyet » Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
nyet
Administrator
Hero Member
*****

Karma: +441/-62
Offline Offline

Posts: 10084


WWW

Considering ME7Sum only works on ME7.1 as of now, and the issue is (primarily I think) with ME 7.1.1 and ME 7.5.....  I don't think it'd make much sense.

It supports pretty much all of the ME7.1.1 and ME7.5 files I can find right now (but not ST10 files of course)

I will add this to ME7Sum time permitting.
Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
stein
Newbie
*

Karma: +1/-0
Offline Offline

Posts: 9



Welp, getting this code after attempting to READ the flash on my 2004 Allroad 2.7t, which I assumed would be safe.

I'm stuck at work. I can continue to attempt to read the ECU, but whenever I save the file, it saves as 0 bytes. I also cannot save a new file, only overwrite an existing file, otherwise I get a windows exception saying "the file could not be found." When writing the just-read binary.

Lame first post, I know, but I'm just trying to get home.

edit: I am using a blue ebay OBD2 cable. I was able to get to 100% of the read, which opens up the save prompt. Not sure why its having issues actually saving the file.
« Last Edit: January 03, 2019, 07:01:43 PM by stein » Logged
Risky
Full Member
***

Karma: +3/-0
Offline Offline

Posts: 93



Welp, getting this code after attempting to READ the flash on my 2004 Allroad 2.7t, which I assumed would be safe.

I'm stuck at work. I can continue to attempt to read the ECU, but whenever I save the file, it saves as 0 bytes. I also cannot save a new file, only overwrite an existing file, otherwise I get a windows exception saying "the file could not be found." When writing the just-read binary.

Lame first post, I know, but I'm just trying to get home.

edit: I am using a blue ebay OBD2 cable. I was able to get to 100% of the read, which opens up the save prompt. Not sure why its having issues actually saving the file.

Just re-flash file to it( original read ). If your having trouble connecting, disconnect negative cable to battery then reconnect, switch ignition on and you should be good to go. I had this issue with my Passat.
Logged
stein
Newbie
*

Karma: +1/-0
Offline Offline

Posts: 9



Just re-flash file to it( original read ). If your having trouble connecting, disconnect negative cable to battery then reconnect, switch ignition on and you should be good to go. I had this issue with my Passat.
Thanks, that's the current plan. Thankfully no connection issues. I was nervous at first because my first few read attempts ended up just saving a 0-byte file...
I also found an image from Daz from 2014 specifically to fix this issue that I may use as my starting point, or I'll diff the binaries. I'm assuming its the single-byte fix here.
Also to avoid further thread derail, I'll shift my troubleshooting discussion over to http://nefariousmotorsports.com/forum/index.php?topic=15459.0.
Logged
323toslow
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 3



Here's the fix.

Open your file in a hex editor and find the follwing string:

"DB 00 28 02 84 00 ?? ?? C2 F4 ?? ?? 66 F4 80 00 2D"

After finding this, change the last byte from 2D to 0D

2004 B5.5 Passat 1.8t AWM

This post saved my butt. Im not new to tuning bmw with siemens ms42, so imagine the brick in my undies after doing my first read on our main vehicle and it becoming inoperable. Thank you to those who figured this out, and those who have built these pieces of software.
Logged
Pages: 1 ... 3 4 [5]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.026 seconds with 18 queries. (Pretty URLs adds 0s, 0q)