Pages: [1]
Author Topic: Connects, but cant get passed security on bench. 2001 A4 018ch ecu  (Read 223 times)
Hindra
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 14



I can connect, read and write fine with the ecu in the car, but with the same laptop/cable at my desk I cant get passed security. A buddy made the harness for me, he said the only thing he did different was no power in pin 21, I have no immobilizer. I am not trying bootmode, Ive got the ecu setup with 13.5v. Am I mistaken, will Nefmoto not do bench reads? For some reason I thought it could.
Logged
Auriaka
Jr. Member
**

Karma: +2/-1
Offline Offline

Posts: 46



« Reply #1 on: June 29, 2020, 11:39:08 PM »

I do bench reads with nefmoto with 018 CH all the time.

I can tell you what pins im using on my setup tomorrow, but it does work.
Logged
Marty
Hero Member
*****

Karma: +159/-227
Offline Offline

Posts: 1583


« Reply #2 on: June 30, 2020, 12:43:10 AM »

I can connect, read and write fine with the ecu in the car, but with the same laptop/cable at my desk I cant get passed security. A buddy made the harness for me, he said the only thing he did different was no power in pin 21, I have no immobilizer. I am not trying bootmode, Ive got the ecu setup with 13.5v. Am I mistaken, will Nefmoto not do bench reads? For some reason I thought it could.
Post log from flasher
Logged

fukenbroken
Hero Member
*****

Karma: +113/-8
Offline Offline

Posts: 972


mk4 1.8T AUM


« Reply #3 on: June 30, 2020, 10:40:36 AM »

21 and 121 should be wired
Logged
Hindra
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 14


« Reply #4 on: June 30, 2020, 09:09:47 PM »

Post log from flasher

Sorry I didnt do this with my original post.

30/Jun/2020 09:05:44.299: LOG: Setting Address: 0x01 KeyByte1: 0x6B KeyByte2: 0x0F
30/Jun/2020 09:05:44.359: LOG: Opened FTDI device.
30/Jun/2020 09:05:44.363: LOG: FTDI device info - Description: FT232R USB UART Serial Number: AH075J38 Device Type: FT_DEVICE_232R ID: 0x4036001 Device Flags: 0x0
30/Jun/2020 09:05:44.638: USER: Validated FTDI device is in dumb mode.
30/Jun/2020 09:05:44.655: LOG: Starting send receive thread.
30/Jun/2020 09:05:44.666: LOG: Send receive thread now started.
30/Jun/2020 09:05:44.672: USER: Disconnected
30/Jun/2020 09:05:44.700: LOG: Setting communication timings to defaults.
30/Jun/2020 09:05:44.706: LOG: Set timing parameters to defaults.
30/Jun/2020 09:05:44.711: USER: Connecting...
30/Jun/2020 09:05:44.737: LOG: Setting communication timings to defaults.
30/Jun/2020 09:05:44.744: USER: Starting slow init connection.
30/Jun/2020 09:05:47.350: USER: Connecting to address 0x01.
30/Jun/2020 09:05:49.529: USER: Slow init succeeded.
30/Jun/2020 09:05:49.534: LOG: Setting Address: 0x01 KeyByte1: 0x01 KeyByte2: 0x0A
30/Jun/2020 09:05:49.539: USER: Switching to KWP1281 session.
30/Jun/2020 09:05:49.711: LOG: KWP1281 read block
30/Jun/2020 09:05:49.775: LOG: KWP1281 sent block
30/Jun/2020 09:05:50.083: LOG: KWP1281 read block
30/Jun/2020 09:05:50.147: LOG: KWP1281 sent block
30/Jun/2020 09:05:50.325: LOG: KWP1281 read block
30/Jun/2020 09:05:50.389: LOG: KWP1281 sent block
30/Jun/2020 09:05:50.534: LOG: KWP1281 read block
30/Jun/2020 09:05:50.600: LOG: KWP1281 sent block
30/Jun/2020 09:05:50.636: LOG: KWP1281 read block
30/Jun/2020 09:05:50.700: LOG: KWP1281 sent block
30/Jun/2020 09:05:50.705: USER: KWP1281 connect info: 4B0906018CH 1.8L R4/5VT     G   0002 ~ö÷w
30/Jun/2020 09:05:52.210: USER: Connecting to address 0x01.
30/Jun/2020 09:05:54.397: USER: Slow init succeeded.
30/Jun/2020 09:05:54.403: LOG: Setting Address: 0x01 KeyByte1: 0x6F KeyByte2: 0x0F
30/Jun/2020 09:05:54.410: USER: Switching to KWP2000 session.
30/Jun/2020 09:05:54.416: USER: Connected
30/Jun/2020 09:05:56.951: LOG: Sent message with service ID TesterPresent
30/Jun/2020 09:05:56.993: LOG: Received message with service ID: TesterPresentPositiveReponse
30/Jun/2020 09:05:59.469: LOG: Sent message with service ID TesterPresent
30/Jun/2020 09:05:59.509: LOG: Received message with service ID: TesterPresentPositiveReponse
30/Jun/2020 09:06:01.989: LOG: Sent message with service ID TesterPresent
30/Jun/2020 09:06:02.033: LOG: Received message with service ID: TesterPresentPositiveReponse
30/Jun/2020 09:06:04.508: LOG: Sent message with service ID TesterPresent
30/Jun/2020 09:06:04.548: LOG: Received message with service ID: TesterPresentPositiveReponse
30/Jun/2020 09:06:07.026: LOG: Sent message with service ID TesterPresent
30/Jun/2020 09:06:07.062: LOG: Received message with service ID: TesterPresentPositiveReponse
30/Jun/2020 09:06:09.545: LOG: Sent message with service ID TesterPresent
30/Jun/2020 09:06:09.586: LOG: Received message with service ID: TesterPresentPositiveReponse
30/Jun/2020 09:06:10.092: LOG: User Prompt - Title: Confirm Full Read ECU Flash Memory Message: If you are ready to read, confirm the following things:
1) You have loaded a valid memory layout for the ECU.
2) The engine is not running.
Note: Some non-standard flash memory chips may prevent reading the flash memory.

Click OK to confirm, otherwise Cancel. Result: OK
30/Jun/2020 09:06:10.098: LOG: Disabling Windows sleep mode.
30/Jun/2020 09:06:10.113: USER: Reading ECU flash memory.
30/Jun/2020 09:06:10.137: LOG: Reading ECU identification option: 0x9C
30/Jun/2020 09:06:10.156: LOG: Sent message with service ID ReadECUIdentification
30/Jun/2020 09:06:10.205: LOG: Received message with service ID: ReadECUIdentificationPositiveResponse
30/Jun/2020 09:06:10.214: LOG: Read ECU identification option: 0x9C
30/Jun/2020 09:06:10.219: LOG: Successfully read ECU identification information
30/Jun/2020 09:06:10.233: USER: ECU reports programming session preconditions have been met.
30/Jun/2020 09:06:10.241: USER: Negotiating communication timings.
30/Jun/2020 09:06:10.246: LOG: Reading current communication timings.
30/Jun/2020 09:06:10.296: LOG: Sent message with service ID AccessTimingParameters
30/Jun/2020 09:06:10.337: LOG: Received message with service ID: AccessTimingParametersPositiveResponse
30/Jun/2020 09:06:10.344: LOG: Set timing parameters to new values.
30/Jun/2020 09:06:10.349: LOG: Setting communication timing to defaults.
30/Jun/2020 09:06:10.399: LOG: Sent message with service ID AccessTimingParameters
30/Jun/2020 09:06:10.442: LOG: Received message with service ID: AccessTimingParametersPositiveResponse
30/Jun/2020 09:06:10.448: LOG: Reading current communication timings.
30/Jun/2020 09:06:10.498: LOG: Sent message with service ID AccessTimingParameters
30/Jun/2020 09:06:10.546: LOG: Received message with service ID: AccessTimingParametersPositiveResponse
30/Jun/2020 09:06:10.551: USER: Successfully changed to new communication timings.
30/Jun/2020 09:06:10.558: USER: Requesting security access.
30/Jun/2020 09:06:10.576: LOG: Sent message with service ID SecurityAccess
30/Jun/2020 09:06:10.614: LOG: Received message with service ID: NegativeResponse
30/Jun/2020 09:06:10.620: LOG: Received negative response for service ID: SecurityAccess, with response code: GeneralReject
30/Jun/2020 09:06:10.627: USER: ECU reports that security access request was rejected.
30/Jun/2020 09:06:10.635: LOG: Starting ProgrammingSession diagnostic session with 38400 baud rate.
30/Jun/2020 09:06:10.640: USER: Starting diagnostic session.
30/Jun/2020 09:06:10.662: LOG: Sent message with service ID StartDiagnosticSession
30/Jun/2020 09:06:10.704: LOG: Received message with service ID: NegativeResponse
30/Jun/2020 09:06:10.710: LOG: Received negative response for service ID: StartDiagnosticSession, with response code: RequestCorrectlyReceived_ResponsePending
30/Jun/2020 09:06:10.744: LOG: Received message with service ID: NegativeResponse
30/Jun/2020 09:06:10.750: LOG: Received negative response for service ID: StartDiagnosticSession, with response code: RequestCorrectlyReceived_ResponsePending
30/Jun/2020 09:06:10.784: LOG: Received message with service ID: NegativeResponse
30/Jun/2020 09:06:10.790: LOG: Received negative response for service ID: StartDiagnosticSession, with response code: RequestCorrectlyReceived_ResponsePending
30/Jun/2020 09:06:10.824: LOG: Received message with service ID: NegativeResponse
30/Jun/2020 09:06:10.830: LOG: Received negative response for service ID: StartDiagnosticSession, with response code: RequestCorrectlyReceived_ResponsePending
30/Jun/2020 09:06:10.864: LOG: Received message with service ID: NegativeResponse
30/Jun/2020 09:06:10.869: LOG: Received negative response for service ID: StartDiagnosticSession, with response code: RequestCorrectlyReceived_ResponsePending
30/Jun/2020 09:06:20.681: LOG: Sent message with service ID TesterPresent
30/Jun/2020 09:06:20.783: LOG: Message received no replies.
30/Jun/2020 09:06:20.788: LOG: Resending message. Send attempts: 2
30/Jun/2020 09:06:20.808: LOG: Sent message with service ID TesterPresent
30/Jun/2020 09:06:20.912: LOG: Message received no replies.
30/Jun/2020 09:06:20.917: LOG: Resending message. Send attempts: 3
30/Jun/2020 09:06:20.938: LOG: Sent message with service ID TesterPresent
30/Jun/2020 09:06:21.040: LOG: Message received no replies.
30/Jun/2020 09:06:21.045: LOG: Failed to send message 3 times, message send failed.
30/Jun/2020 09:06:21.050: USER: Disconnecting because no response was received for the Tester Present message.
30/Jun/2020 09:06:21.056: USER: Disconnected
30/Jun/2020 09:06:21.075: USER: Reading ECU flash memory failed.
30/Jun/2020 09:06:21.095: LOG: Closing FTDI device.
30/Jun/2020 09:06:21.112: LOG: Send receive thread now terminated.
30/Jun/2020 09:06:23.766: LOG: User Prompt - Title: Reading ECU Flash Memory Complete Message: Reading ECU flash memory failed. Result: OK
30/Jun/2020 09:06:23.772: USER: 100% complete.
30/Jun/2020 09:06:23.794: LOG: Restoring Windows sleep mode.
30/Jun/2020 09:06:29.109: LOG: Closing NefMoto VW Audi ME7 Flasher Logger 1.9.4.3
Logged
Hindra
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 14


« Reply #5 on: June 30, 2020, 09:12:23 PM »

21 and 121 should be wired

I am fairly certain both of those are not wired, those are definitely needed for 018ch? I will get to that this weekend.

Edit: My buddy told me that there was no wire in pin 21 in the factory harness.
« Last Edit: July 01, 2020, 04:38:32 PM by Hindra » Logged
Hindra
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 14


« Reply #6 on: July 02, 2020, 10:11:25 PM »

21 and 121 should be wired

You were right, put power on pin 121 and I can read and write from the bench harness. Thank you!
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.019 seconds with 18 queries. (Pretty URLs adds 0s, 0q)