Pages: 1 ... 4 5 [6] 7 8 ... 11
Author Topic: NefMoto ME7 ECU Flasher and Data Logger Version 1.9.3.2  (Read 226521 times)
adidascoin
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 3


« Reply #75 on: April 30, 2014, 02:25:15 PM »

Will this work at all on Volvo ME7.1? And did Dilemma's ME7.1 Normal mode flash tool ever get done?Huh
Logged
PwrTuning
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 1


« Reply #76 on: May 29, 2014, 11:31:32 PM »

This is the version 1.9.3.2 release of the NefMoto software.

Changes in this version:
-Removed Validate Memory Layout operation because flashing operations already validate the layout, and it could cause Programming Not Complete errors on some ECUs.
-Made flash writing operations only validate sector checksums after flash writing has successfully started. This prevents Invalid Checksum errors on some ECUs that would enter programming mode but refuse to allow flash writing.
-Fixed a bug with overwriting a file when saving a read flash causing the program to freeze.
-Fixed a bug with negotiating timing parameters failing on some ECU types when entering programming mode.
-Added better support for detecting supported baud rates on ECUs that don't respond to messages on unsupported baud rates.

Fast data logging can read up to 84 variables at a time with samples rates as high as 50 samples per second. The sample rate defaults to 10 samples per second. High sample rates can overload the ECU and cause communication disconnections. This same problem effects the ME7 Logger when attempting to read too many variables with sample rates that are too high. I recommend only logging the variables you are interested in at sample rate you need. The data logging method that this software and ME7 Logger use are non-standard and as such are able to overload the ECU if used irresponsibly.

You can read about the software on the wiki: http://www.nefariousmotorsports.com/wiki/index.php/NefMoto_ECU_Flashing_Software

Also make sure you have the FTDI D2XX driver installed: http://www.ftdichip.com/Drivers/D2XX.htm

I have tried to install it on my Windows 8.1 but I get the error message that I am attaching. What am I doing wrong? Please help!!
Thanks!!!
Logged
tjwasiak
Sr. Member
****

Karma: +25/-0
Offline Offline

Posts: 420


« Reply #77 on: May 30, 2014, 04:33:37 AM »

Have you tried to run the installer as Administrator or how is it called in Windows 8.1?
Logged
The Great NY
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 4


« Reply #78 on: July 09, 2014, 06:29:17 AM »

This is the version 1.9.3.2 release of the NefMoto software.

Changes in this version:
-Removed Validate Memory Layout operation because flashing operations already validate the layout, and it could cause Programming Not Complete errors on some ECUs.
-Made flash writing operations only validate sector checksums after flash writing has successfully started. This prevents Invalid Checksum errors on some ECUs that would enter programming mode but refuse to allow flash writing.
-Fixed a bug with overwriting a file when saving a read flash causing the program to freeze.
-Fixed a bug with negotiating timing parameters failing on some ECU types when entering programming mode.
-Added better support for detecting supported baud rates on ECUs that don't respond to messages on unsupported baud rates.

Fast data logging can read up to 84 variables at a time with samples rates as high as 50 samples per second. The sample rate defaults to 10 samples per second. High sample rates can overload the ECU and cause communication disconnections. This same problem effects the ME7 Logger when attempting to read too many variables with sample rates that are too high. I recommend only logging the variables you are interested in at sample rate you need. The data logging method that this software and ME7 Logger use are non-standard and as such are able to overload the ECU if used irresponsibly.

You can read about the software on the wiki: http://www.nefariousmotorsports.com/wiki/index.php/NefMoto_ECU_Flashing_Software

Also make sure you have the FTDI D2XX driver installed: http://www.ftdichip.com/Drivers/D2XX.htm


hello,

I have installed the Nefmoto Software.  Im trying to setup to start reading and writing my S60R (ME7), but im having trouble even getting the the software to recognize my VAG KKL cable.  when the software is launched it just stays on the KWP2000 setting and refresh devices doesnt work or at least it doesnt show my device.

I've re-installed the FTDI drivers like four or five times and still have not gotten any improvements.

Any information on whats going on? maybe im doing something wrong, or missed a step.  Let me know, thanks.
Logged
The Great NY
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 4


« Reply #79 on: July 09, 2014, 06:30:49 AM »

also, wondering if i need to buy a license? if so how do I do that and where?
Logged
ljscodex
Newbie
*

Karma: +1/-1
Offline Offline

Posts: 13


« Reply #80 on: July 30, 2014, 11:34:13 AM »

hi, thanks for your great work!

its Awesome!.

i need to read and flash (for immo off) 95040 of my A4 B6 with RB4, with this tool  can i do it?.

i was reading about me75_eeprom_95040 shell tool, but only for read via obd.

Thanks again!.
Logged
turboat
Hero Member
*****

Karma: +43/-2
Offline Offline

Posts: 619


« Reply #81 on: July 30, 2014, 01:42:37 PM »

Nef cannot flash the 95040, you need to use argdubs tool for flashing that. http://nefariousmotorsports.com/forum/index.php?topic=1168.0title=
Logged
Bi-turbo
Full Member
***

Karma: +1/-7
Offline Offline

Posts: 164


« Reply #82 on: August 07, 2014, 12:26:34 AM »

Will this ever be able to work with the 551C?
Logged
eliotroyano
Hero Member
*****

Karma: +42/-7
Offline Offline

Posts: 765


« Reply #83 on: August 31, 2014, 09:42:16 AM »

Hi friends I have been trying to connect in bootmode but all the time I receive this error:
31/ago/2014 11:15:59.156: USER: Connecting...
31/ago/2014 11:15:59.187: USER: Starting bootstrap loader upload.
31/ago/2014 11:15:59.187: USER: Sent bootstrap init zero byte.
31/ago/2014 11:16:02.187: USER: Sent bootstrap init zero byte.
31/ago/2014 11:16:05.187: USER: Sent bootstrap init zero byte.
31/ago/2014 11:16:08.187: USER: Bootstrap loader upload failed. Failed to receive device ID response for init zero byte.
31/ago/2014 11:16:08.187: USER: Disconnected
ECU is 06A906032NL 0261208164 ME7.5. I am using WinXP SP3.
Can you help me?
« Last Edit: August 31, 2014, 09:50:44 AM by eliotroyano » Logged
ddillenger
Hero Member
*****

Karma: +631/-20
Offline Offline

Posts: 5640


« Reply #84 on: August 31, 2014, 11:35:50 AM »

Nefmoto doesn't do bootmode! That part was never finished.
Logged

Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience!

Email/Google chat:
DDillenger84(at)gmail(dot)com

Email>PM
Tony@NefMoto
Administrator
Hero Member
*****

Karma: +126/-4
Offline Offline

Posts: 1389


2001.5 Audi S4 Stage 3


« Reply #85 on: September 02, 2014, 07:30:36 PM »

Nefmoto doesn't do bootmode! That part was never finished.

Right now with the NefMoto software you should be able to connect in boot mode, but I never finished reading or writing. I do hope to finish that this year perhaps.Smiley
Logged

Remember you have to log in if you want to see the file attachments!
Info or questions, please add to the wiki: http://www.nefariousmotorsports.com/wiki
Follow NefMoto developments on Twitter: http://twitter.com/nefmoto
ddillenger
Hero Member
*****

Karma: +631/-20
Offline Offline

Posts: 5640


« Reply #86 on: September 02, 2014, 07:53:00 PM »

Right now with the NefMoto software you should be able to connect in boot mode, but I never finished reading or writing. I do hope to finish that this year perhaps.Smiley

I guess it works for TESTING bootmode, but once you query the ecu IN bootmode you have to shut it down and reinitialize anyway, so I don't even bother explaining that part-lol.

Just adds to the confusion.
Logged

Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience!

Email/Google chat:
DDillenger84(at)gmail(dot)com

Email>PM
TCSTigersClaw
Sr. Member
****

Karma: +15/-6
Offline Offline

Posts: 353



« Reply #87 on: September 03, 2014, 03:51:47 AM »

Right now with the NefMoto software you should be able to connect in boot mode, but I never finished reading or writing. I do hope to finish that this year perhaps.Smiley

Will nefmoto be able to read other Ecus , like MED9 ?

I have ori tools ,but it is so fast with ME7.5 that I prefer it Smiley
Logged

VAG cars newbie tuner Smiley
Bi-turbo
Full Member
***

Karma: +1/-7
Offline Offline

Posts: 164


« Reply #88 on: September 24, 2014, 06:21:28 AM »

Connecting to address 0x01.
Slow init succeeded.
Switching to KWP1281 session.
KWP1281 connect info: THIS-IS-THE-RAM-PROGRAM-           

The ECU is in programming mode, and needs the ignition turned off to reset.
If this does not end programming mode, the ECU likely believes the flash memory is not programmed correctly.
Reading all ECU info failed.   

Any ideas?

Logged
ddillenger
Hero Member
*****

Karma: +631/-20
Offline Offline

Posts: 5640


« Reply #89 on: September 24, 2014, 06:33:44 AM »

Connecting to address 0x01.
Slow init succeeded.
Switching to KWP1281 session.
KWP1281 connect info: THIS-IS-THE-RAM-PROGRAM-           

The ECU is in programming mode, and needs the ignition turned off to reset.
If this does not end programming mode, the ECU likely believes the flash memory is not programmed correctly.
Reading all ECU info failed.   

Any ideas?



This has been covered 10000 times now.

You have to force the ecu into recognizing the programming session has ended. If it didn't do it after the flash, do a full read. If that doesn't work, you need to bootflash an eeprom backup taken before the problem.
Logged

Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience!

Email/Google chat:
DDillenger84(at)gmail(dot)com

Email>PM
Pages: 1 ... 4 5 [6] 7 8 ... 11
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.027 seconds with 17 queries. (Pretty URLs adds 0s, 0q)