Pages: 1 ... 7 8 [9] 10 11 ... 24
Author Topic: Emissions delete and setting actual readiness  (Read 158693 times)
masterj
Hero Member
*****

Karma: +53/-4
Offline Offline

Posts: 1049



WWW
« Reply #120 on: October 04, 2012, 04:20:42 PM »

Mine are disconnected and read 0.44v.

Set CWKONLS to correct number of your o2 sensors Wink And you will see ~0V as it should be with disconnected sensor... Smiley
Logged

nyet
Administrator
Hero Member
*****

Karma: +417/-48
Offline Offline

Posts: 9253


WWW
« Reply #121 on: October 04, 2012, 04:27:49 PM »

As usual, if you guys find things i need to add to the s4wiki, PLEASE pm me or edit the page yourself Smiley
Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
phila_dot
Hero Member
*****

Karma: +157/-11
Online Online

Posts: 1704


« Reply #122 on: October 04, 2012, 06:03:57 PM »

Sounds like you found the problem in LALIUS.

Set CWKONLS to correct number of your o2 sensors Wink And you will see ~0V as it should be with disconnected sensor... Smiley

Ahh...gotcha. It shouldn't make any difference anyway as nothing should be using it since everything is disabled. I think I had a reason for not changing CWKONLS, but now I will have to go back over it and see exactly everything it affects.
Logged
masterj
Hero Member
*****

Karma: +53/-4
Offline Offline

Posts: 1049



WWW
« Reply #123 on: October 04, 2012, 06:09:06 PM »

Sounds like you found the problem in LALIUS.

Ahh...gotcha. It shouldn't make any difference anyway as nothing should be using it since everything is disabled. I think I had a reason for not changing CWKONLS, but now I will have to go back over it and see exactly everything it affects.

Please do... I haven't scanned through whole FR for this
Logged

phila_dot
Hero Member
*****

Karma: +157/-11
Online Online

Posts: 1704


« Reply #124 on: October 04, 2012, 08:52:37 PM »

CWKONLS set/clears B_lsv (B1S1), B_lsv2 (B2S1), B_lsh (B1S2), and B_lsh2 (B2S2).

They get directly referenced as follows:

TC1MOD : all four
DLSSA    : all four
GGLSH    : all four
GGLSV    : B_lsv and B_lsv2

I haven't gone through and determined exactly all of the effects but from what I can tell, nothing but good can come from clearing B_lsh and B_lsh2 with CWKONLS.

I think my original concern was this possibly affecting readiness, but even if it does we should be able to overcome that by setting SRYLS to 0.
Logged
phila_dot
Hero Member
*****

Karma: +157/-11
Online Online

Posts: 1704


« Reply #125 on: October 06, 2012, 04:21:50 PM »

masterj had to bring this up and it forced me to reevalute the post cat O2 sensor codeout, but I think that I finally have it nailed down.

Yesterday, I went through everything decided to change a few things. First, I turned the error classes back on because if everything is done correctly then they shouldn't be a factor. I also change CWKONLS from 51 to 17. I was not happy to find that after flashing, I was now throwing P1118 and P1122 O2 sensor heating open circuit sensor 2 banks 1 and 2.

I spent a few hours searching before I finally narrowed it down to ESKONF and a few more hours to figure out exactly what need to be done. Bits 6 and 7 need to be set at 10C7A and bits 2 and 3 need to be set at 10C7B to disable post cat O2 sensor heater amplifiers.

Parameter  Location  Original(hex)  Original(dec)  New(hex)  New(dec)
ESKONF 10C7A 00 0 C0 192
ESKONF (M box) 10C7B F3 243 FF 255
ESKONF (L box) 10C7B C3 195 CF 207

After flashing the file with this being the only change, the codes are now gone.
« Last Edit: October 06, 2012, 04:40:15 PM by phila_dot » Logged
phila_dot
Hero Member
*****

Karma: +157/-11
Online Online

Posts: 1704


« Reply #126 on: October 06, 2012, 04:32:59 PM »

See below for my current settings for rear O2 sensor removal:

CDKAT = 0
CWDLSAHK = 0
CDHSH = 0
CDHSHE = 0
CDLATV = 0
CDLASH = 0
CDLSH = 0
CDLSHV = 0
CLRHK = 5
CWKONLS = 17
ESKONF - as described above

I have not blocked any error classes, because there is no diagnosis.
Logged
nyet
Administrator
Hero Member
*****

Karma: +417/-48
Offline Offline

Posts: 9253


WWW
« Reply #127 on: October 06, 2012, 04:40:15 PM »

Phila: thanks for the info! I will update the s4 wiki time permitting.
Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
phila_dot
Hero Member
*****

Karma: +157/-11
Online Online

Posts: 1704


« Reply #128 on: October 06, 2012, 04:44:38 PM »

Untested nugget:

SLS and SLV appear to be bits 4 and 5 at 10C79 and bits 4 and 5 at 10C7B
Logged
masterj
Hero Member
*****

Karma: +53/-4
Offline Offline

Posts: 1049



WWW
« Reply #129 on: October 07, 2012, 05:00:09 AM »

masterj had to bring this up and it forced me to reevalute the post cat O2 sensor codeout, but I think that I finally have it nailed down.

Yesterday, I went through everything decided to change a few things. First, I turned the error classes back on because if everything is done correctly then they shouldn't be a factor. I also change CWKONLS from 51 to 17. I was not happy to find that after flashing, I was now throwing P1118 and P1122 O2 sensor heating open circuit sensor 2 banks 1 and 2.

I spent a few hours searching before I finally narrowed it down to ESKONF and a few more hours to figure out exactly what need to be done. Bits 6 and 7 need to be set at 10C7A and bits 2 and 3 need to be set at 10C7B to disable post cat O2 sensor heater amplifiers.

Parameter  Location  Original(hex)  Original(dec)  New(hex)  New(dec)
ESKONF 10C7A 00 0 C0 192
ESKONF (M box) 10C7B F3 243 FF 255
ESKONF (L box) 10C7B C3 195 CF 207

After flashing the file with this being the only change, the codes are now gone.

Thank you! I'm going to try this and report back

UPDATE: Can't find ESKONF on my bin nowhere... at 10C7A there's axis for KFKHFM. Could you take a look?
« Last Edit: October 07, 2012, 05:17:59 AM by masterj » Logged

masterj
Hero Member
*****

Karma: +53/-4
Offline Offline

Posts: 1049



WWW
« Reply #130 on: October 07, 2012, 02:35:54 PM »

Maybe ESKONF in my bin is @ 10C4F & 10C50?? Confused here...  Undecided
Logged

phila_dot
Hero Member
*****

Karma: +157/-11
Online Online

Posts: 1704


« Reply #131 on: October 07, 2012, 03:39:06 PM »

Maybe ESKONF in my bin is @ 10C4F & 10C50?? Confused here...  Undecided

LSHHK should be bits 6 and 7 at 10C50.

Edit: You would want to change it from 48 to 240 (dec).
« Last Edit: October 07, 2012, 04:12:52 PM by phila_dot » Logged
masterj
Hero Member
*****

Karma: +53/-4
Offline Offline

Posts: 1049



WWW
« Reply #132 on: October 07, 2012, 04:20:26 PM »

LSHHK should be bits 6 and 7 at 10C50.

Edit: You would want to change it from 48 to 240 (dec).

Thank you! Gonna test this
Logged

professor
Sr. Member
****

Karma: +23/-0
Offline Offline

Posts: 408



« Reply #133 on: October 08, 2012, 01:08:58 AM »

So i removed via ESKONF N249, N112, N75, SAI but in readiness i get FAILED on oxygen sensor(s) and SAI.
Fuel trims are working ok (-0.2, -3.1), on oxygen sensors only cat DTC is out.
Weird since all were passed before doing those changes.



« Last Edit: October 08, 2012, 10:06:43 AM by professor » Logged

Seat Ibiza MK4 Cupra 1.8t 20V, stg3.
"Those 1.8T 20V machines are really tough" ©
phila_dot
Hero Member
*****

Karma: +157/-11
Online Online

Posts: 1704


« Reply #134 on: October 08, 2012, 12:12:55 PM »

So i removed via ESKONF N249, N112, N75, SAI but in readiness i get FAILED on oxygen sensor(s) and SAI.
Fuel trims are working ok (-0.2, -3.1), on oxygen sensors only cat DTC is out.
Weird since all were passed before doing those changes.

You must have done something wrong.

I turned off just post cat O2 sensor heater with ESKONF and associated codewords and it had no effect on readiness.

Have you changed the codewords for SAI also, or just ESKONF?
Logged
Pages: 1 ... 7 8 [9] 10 11 ... 24
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.026 seconds with 17 queries. (Pretty URLs adds 0s, 0q)