Pages: 1 2 [3] 4
Author Topic: ME7.1.1/7.5 Programming Not Finished - P0602, P1681 or 18089  (Read 39140 times)
ddillenger
Hero Member
*****

Karma: +618/-19
Offline Offline

Posts: 5647


« Reply #30 on: June 01, 2014, 11:46:19 AM »

Hard to comment on that. I'm using V18.whatever they are at now.

The clones are pretty good though, certainly more reliable than nefmoto.
Logged

Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience!

Email/Google chat:
DDillenger84(at)gmail(dot)com

Email>PM
mounty
Full Member
***

Karma: +0/-0
Offline Offline

Posts: 119


« Reply #31 on: June 28, 2014, 04:51:55 AM »

So with my v8 allroad being a 2004 I'm going to have this issue as well?
Logged
kosiik
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 2


« Reply #32 on: August 10, 2014, 02:05:55 AM »

Please immo EEprom 95040 files ?
thanks Wink

Ecu reports dtc unfinished programming Sad
« Last Edit: August 10, 2014, 05:13:22 AM by kosiik » Logged
ddillenger
Hero Member
*****

Karma: +618/-19
Offline Offline

Posts: 5647


« Reply #33 on: September 01, 2014, 01:47:55 PM »

fix: http://nefariousmotorsports.com/forum/index.php?topic=6719.0
« Last Edit: July 17, 2017, 01:32:32 PM by nyet » Logged

Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience!

Email/Google chat:
DDillenger84(at)gmail(dot)com

Email>PM
nyet
Administrator
Hero Member
*****

Karma: +443/-62
Offline Offline

Posts: 10107


WWW

http://nefariousmotorsports.com/forum/index.php?topic=2200.msg65208#msg65208

4B0906018DQ
Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
ddillenger
Hero Member
*****

Karma: +618/-19
Offline Offline

Posts: 5647




2003+ will experience this.

Logged

Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience!

Email/Google chat:
DDillenger84(at)gmail(dot)com

Email>PM
edgy
Full Member
***

Karma: +2/-0
Offline Offline

Posts: 66



I ran into this today using MPPS with a 4B0906018DQ ECU...
Logged

2002 S4 full stg 3
2001 S4 stg 2
2001 TT 225 stg 2
1988 80q 4.2
2005 A4 (the wife's)
Ionut
Full Member
***

Karma: +3/-3
Offline Offline

Posts: 89



Same here with an 2005 Audi A4 1.8T 8E0909518AQ
Just read over OBD and ecu remained in programming session. P1681 arrived and never goes away. Car cranking but engine doesn`t start.
When connecting with VCDS it disconnects after a minute or two and then connects again, if this matters.
Would the change from 0x2D to 0x0D prevent that fault to came up and engine starts well after that? or the EEPROM is corrupt too?
Logged
ddillenger
Hero Member
*****

Karma: +618/-19
Offline Offline

Posts: 5647



Same here with an 2005 Audi A4 1.8T 8E0909518AQ
Just read over OBD and ecu remained in programming session. P1681 arrived and never goes away. Car cranking but engine doesn`t start.
When connecting with VCDS it disconnects after a minute or two and then connects again, if this matters.
Would the change from 0x2D to 0x0D prevent that fault to came up and engine starts well after that? or the EEPROM is corrupt too?

It'll run fine. Eeprom is fine.
Logged

Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience!

Email/Google chat:
DDillenger84(at)gmail(dot)com

Email>PM
Ionut
Full Member
***

Karma: +3/-3
Offline Offline

Posts: 89



The file also had some other changes than stock (after compared to stock and looked into bottom of file the things are clear. SW is made by a local tuner that i know personally, but not for good work that he`s doing). I can send you ORI and file pulled out from car to tell me what is that modified part of file that doesn`t look to be part of a map and is not the checksum from end of file neither.
Logged
Ionut
Full Member
***

Karma: +3/-3
Offline Offline

Posts: 89



Recovered ECU few moments ago. Deleted tuner signature, noread tag, changed that byte you found and flashed file via OBD with FGTech v54. Car started from first attempt.
Before that tried to read 2 times to unlock ecu with no luck.

EEPROM seems to be fine, but i`ve asked him to take off ECU and come to me to make a backup to EEPROM too.... you don`t know what can happen with the ECU in the future.
Logged
KBATTPO
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 4



Got the P1681 after simply reading my 4Z7907551S (2004 Allroad 2.7T manual). Did some searching on this site and came upon this thread. Flashed the 4Z7907551R.bin into my ECU. It did indeed get the car to start again but introduced a bunch of new codes:

Code:
-------------------------------------------------------------------------------
Address 08: Auto HVAC        Labels: 4B0-820-043-MY2.lbl
   Part No: 4B0 820 043 AQ
   Component: A6-Klimavollautomat 0208 
   Coding: 00010
   Shop #: WSC 06133 

1 Fault Found:
01314 - Engine Control Module
            49-10 - No Communications - Intermittent

-------------------------------------------------------------------------------
Address 17: Instruments        Labels: 4B0-920-xxx-17.lbl
   Part No: 4B0 920 983 FX
   Component: KOMBI+WEGFAHRS. VDO D17 
   Coding: 00264
   Shop #: WSC 06133 

1 Fault Found:
01314 - Engine Control Module
            49-10 - No Communications - Intermittent

-------------------------------------------------------------------------------
Address 34: Level Control        Labels: 4Z7-907-553.lbl
   Part No: 4Z7 907 553 F
   Component:  - 2C1A1          D060   
   Coding: 25500
   Shop #: WSC 02334 

1 Fault Found:
01577 - Turn-Off due to Over-Temp
            35-10 -  -  - Intermittent

Needless to say I was not happy at all and began to look for the ways to fix my original 4Z7907551S.bin. Came across this thread: http://nefariousmotorsports.com/forum/index.php?topic=6719.0, edited that one byte, reflashed the original 4Z7907551S.bin into my ECU and the car started from a quarter turn and been running great ever since.

BTW, not only did the 4Z7907551R.bin introduce new codes, it eliminated a few that were set off by my deleting of the SAI system, both EGT sensors and both post-cat OXS sensors.

With the original 4Z7907551S.bin:

Code:
-------------------------------------------------------------------------------
Address 01: Engine        Labels: 078-907-551-AZA.lbl
   Part No: 4Z7 907 551 S
   Component: 2.7L V6/5VT     G   0020 
   Coding: 07715
   Shop #: WSC 02335 

7 Faults Found:
17840 - Secondary Air Injection Solenoid Valve (N112)
            P1432 - 35-00 - Open Circuit
17530 - Oxygen (Lambda) Sensor Heating; B2 S2
            P1122 - 35-00 - Open Circuit
17526 - Oxygen (Lambda) Sensor Heating; B1 S2
            P1118 - 35-00 - Open Circuit
17861 - Exhaust Gas Temp Sensor 1 (G235)
            P1453 - 35-10 - Open or Short to Plus - Intermittent
17865 - Exhaust Gas Temp Sensor 2 (G236)
            P1457 - 35-10 - Open or Short to Plus - Intermittent
17522 - Oxygen (Lambda) Sensor; B1 S2
            P1114 - 35-00 - Internal Resistance too High
17548 - Oxygen (Lambda) Sensor; B2 S2
            P1140 - 35-00 - Internal Resistance too High
Readiness: 0010 1001

vs. with the 4Z7907551R.bin flashed into my ECU:

Code:
-------------------------------------------------------------------------------
Address 01: Engine        Labels: 078-907-551-AZA.lbl
   Part No: 4Z7 907 551 R
   Component: 2.7L V6/5VT     G   0003 
   Coding: 07715
   Shop #: WSC 02335 

3 Faults Found:
17840 - Secondary Air Injection Solenoid Valve (N112)
            P1432 - 35-00 - Open Circuit
17530 - Oxygen (Lambda) Sensor Heating; B2 S2
            P1122 - 35-00 - Open Circuit
17526 - Oxygen (Lambda) Sensor Heating; B1 S2
            P1118 - 35-00 - Open Circuit
Readiness: 0110 1101

In the hex editor the 4Z7907551S.bin and the 4Z7907551R.bin also appear to be rather different. I am glad I am able to use my original 4Z7907551S.bin again.
« Last Edit: July 23, 2015, 08:27:52 AM by KBATTPO » Logged
KBATTPO
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 4



Update.
Thanks to the tip from stuklr, I now have the 4Z7907551R.bin running my Allroad. It took two interrogations and two subsequent erases to get rid of the extra codes, but they are gone now.
Logged
nyet
Administrator
Hero Member
*****

Karma: +443/-62
Offline Offline

Posts: 10107


WWW
« Reply #43 on: July 29, 2016, 03:18:19 PM »

Workaround (.bin ASM patch) here: http://nefariousmotorsports.com/forum/index.php?topic=6719.0
« Last Edit: July 17, 2017, 01:32:12 PM by nyet » Logged

ME7.1 tuning guide (READ FIRST)
ECUx Plot
ME7Sum checksum checker/corrrector for ME7.x

Please do not ask me for tunes. I'm here to help people make their own.

Do not PM me technical questions! Please, ask all questions on the forums! Doing so will ensure the next person with the same issue gets the opportunity to learn from your experience.
Crushing
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 2


« Reply #44 on: March 11, 2018, 09:43:05 PM »

What am I doing wrong? I am still very new at this but I tried full read with nefmoto on my 2004 a6 2.7t, the. It wouldn't start and was throwing codes po602, p1681 and p18089 programming not finished. After reading several posts on the issue I tried full read several times a long with full write/flash, delete codes, not deleting codes, cycling key, disconnecting battery, writing the 4z7907551r .bin instead of stock 4z7907551s .bin with no luck on either file. I don't want to brick my ecu as I haven't had luck with getting it in boot mode with galletto 1260 yet either. I started looking through the hex editor in tuner pro for this threads fix but after an hour of searching I felt like an idiot thinking there is probably a hex search option that would find it quicker. Please tell me what I'm doing wrong and point me in the right direction.

Sent from my SM-G930V using Tapatalk

Logged
Pages: 1 2 [3] 4
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Page created in 0.026 seconds with 18 queries. (Pretty URLs adds 0.001s, 0q)